summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Lallemand <wlallemand@irq6.net>2013-02-24 00:45:10 +0100
committerWilliam Lallemand <wlallemand@irq6.net>2013-02-24 00:45:10 +0100
commitb11928ed98129f0250c80212cf2b3b5fe1ed277d (patch)
tree19720341ad461c960607760231de1ef6421c9e06
parentInitial commit (diff)
downloadsekh-b11928ed98129f0250c80212cf2b3b5fe1ed277d.tar.gz
sekh-b11928ed98129f0250c80212cf2b3b5fe1ed277d.tar.bz2
sekh-b11928ed98129f0250c80212cf2b3b5fe1ed277d.zip
librecad-2.0.0_beta1 forked from science overlay
-rw-r--r--media-gfx/librecad/Manifest2
-rw-r--r--media-gfx/librecad/librecad-2.0.0_beta1.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/media-gfx/librecad/Manifest b/media-gfx/librecad/Manifest
new file mode 100644
index 0000000..9c66eea
--- /dev/null
+++ b/media-gfx/librecad/Manifest
@@ -0,0 +1,2 @@
+DIST librecad-2.0.0_beta1.tar.gz 14807067 SHA256 da1c88f7c201bc972da052e9c8080185b2234b56177661f5c6c3024dd3cd82d0 SHA512 06c4033bab60d12ddd59941079dabb3605eb27f288df5b8fd898776857d9a692955acd5607f661bc18f21371d1348126491f3394ed8d77e0992fa45c81918396 WHIRLPOOL 9c1405f993ee8723d4e5366ce01d2cab16d6bb51aec498e5dcf3dfe212ad09f4f9f8037a23043f2d6708a03cf61e3d0c46cb0db75a8d302cf540cfa06c963ad2
+EBUILD librecad-2.0.0_beta1.ebuild 901 SHA256 821a733f6760526eb9352071aabde6db0298d7b6f23915cec76d0d901ac6da12 SHA512 cc5b941c64285bc5c280ff69505868fe7cca7077c6de4bd37cfc0bf60cc9644e04a6baa9f65707dec1b0d01113a4fdf3069a0b26a6b921129fb2b2bc5d203a27 WHIRLPOOL 9ab8d9c09fc4b8968eb7e62001eda06bbfe68868a2ceeff626c57472aa45cb5da9609c30bec9b4d5b17d02fe950979ebce4ef2430cb6ef1826a3e00c29231874
diff --git a/media-gfx/librecad/librecad-2.0.0_beta1.ebuild b/media-gfx/librecad/librecad-2.0.0_beta1.ebuild
new file mode 100644
index 0000000..2168612
--- /dev/null
+++ b/media-gfx/librecad/librecad-2.0.0_beta1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit qt4-r2 eutils flag-o-matic
+
+DESCRIPTION="An generic 2D CAD program"
+HOMEPAGE="http://www.librecad.org/"
+SRC_URI="https://github.com/LibreCAD/LibreCAD/archive/${PV/_/}.tar.gz ->
+${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+DEPEND="
+ x11-libs/qt-assistant:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-svg:4
+ dev-libs/boost
+ dev-cpp/muParser
+ media-libs/freetype
+ "
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ mv * ${P}
+}
+
+src_prepare() {
+ sed -i -e '/RS_VECTOR2D/ s/^#//' librecad/src/src.pro
+}
+
+src_install() {
+ dobin unix/librecad
+ insinto /usr/share/"${PN}"
+ doins -r unix/resources/*
+ if use doc ; then
+ dohtml -r support/doc/*
+ fi
+ doicon librecad/res/main/"${PN}".png
+ make_desktop_entry "${PN}" LibreCAD "${PN}.png" Graphics
+}