summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Lallemand <wlallemand@irq6.net>2013-02-28 20:47:03 +0100
committerWilliam Lallemand <wlallemand@irq6.net>2013-02-28 20:47:03 +0100
commit7c60f163b7fa78864e901f86f1148bf2c74a13b3 (patch)
tree6595961383b50d248dbf6604c971a0481e052763 /net-im/poezio/poezio-9999.ebuild
parentAdd repo_name (diff)
downloadsekh-7c60f163b7fa78864e901f86f1148bf2c74a13b3.tar.gz
sekh-7c60f163b7fa78864e901f86f1148bf2c74a13b3.tar.bz2
sekh-7c60f163b7fa78864e901f86f1148bf2c74a13b3.zip
poezio git and dependencies
Diffstat (limited to 'net-im/poezio/poezio-9999.ebuild')
-rw-r--r--net-im/poezio/poezio-9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-im/poezio/poezio-9999.ebuild b/net-im/poezio/poezio-9999.ebuild
new file mode 100644
index 0000000..c1e6ae8
--- /dev/null
+++ b/net-im/poezio/poezio-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+PYTHON_DEPEND="3"
+
+EGIT_REPO_URI="git://github.com/sekh/poezio.git"
+
+inherit python git-2
+
+DESCRIPTION="Console XMPP client that looks like most famous IRC clients"
+HOMEPAGE="http://poezio.eu/"
+
+LICENSE="custom"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=dev-python/sleekxmpp-9999 >=dev-python/dnspython3-1.10.0"
+RDEPEND="${DEPEND}"
+
+src_install()
+{
+ emake DESTDIR="${D}" prefix="/usr/" install || die "make install failed"
+}