summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/sleekxmpp')
-rw-r--r--dev-python/sleekxmpp/Manifest3
-rw-r--r--dev-python/sleekxmpp/sleekxmpp-1.1.11.ebuild40
-rw-r--r--dev-python/sleekxmpp/sleekxmpp-9999.ebuild40
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/sleekxmpp/Manifest b/dev-python/sleekxmpp/Manifest
new file mode 100644
index 0000000..1a60ba9
--- /dev/null
+++ b/dev-python/sleekxmpp/Manifest
@@ -0,0 +1,3 @@
+DIST sleekxmpp-1.1.11.tar.gz 971732 SHA256 c6f4a466881dcef0c4d054e690b6fbc24639c24bf366a2e4e45ea781403a20b0 SHA512 0757965a9f1779b2341b412e8383c51161d9f2e97af565127d878c5c61cf40ce660adb20dfa4c509e3e49d142df0a04a74067565b18db168286caeea486bf209 WHIRLPOOL f1541ee6d8d57c575fc831048093505a748120f5eb7280e50ce27cdb47f9de89fe9dc4f99ed3cc7bb354da35d78ce992261bb12489cef24355c781a335766347
+EBUILD sleekxmpp-1.1.11.ebuild 759 SHA256 75b91ca90a97ad7612408751ceffad0212a853bcf5b580509faf102bf1e90197 SHA512 1af0f83687501618c0ced8aad019af7ab9b53d25fd041fdb122654c76e29f4a27b000c9009bbfe0e7eb1aff3671f38f9bcb2b25010a263520af8e35d44f89ac4 WHIRLPOOL 9fb24622b09ab0e8c0f0388327b6f787336c3972299ca6fa569abacbf167d56fa028d475e48e7358c505cbdb99f0ed85457a5639c7e5bb7103ec24e6e05648bd
+EBUILD sleekxmpp-9999.ebuild 750 SHA256 1930abd9df2301a5b30a1f6d6b456c123b1769bbbcb80c5133a895d78c81dbbc SHA512 c38f92660d4a36ef9c23351d6cf654606811855049b8f2604714c403f14e941d265c7ac414f0d5e84da0db1fd92cd94426741b447c0a2f1b6112c3c4916ad248 WHIRLPOOL 876375b55b85179897817127618ac40b3d0e13361b6df841b508a41f490dd5b306210d8e39d7faf0c60aad17bfedb359adf896631dee9a9b57cb70df75db2f6e
diff --git a/dev-python/sleekxmpp/sleekxmpp-1.1.11.ebuild b/dev-python/sleekxmpp/sleekxmpp-1.1.11.ebuild
new file mode 100644
index 0000000..c01a265
--- /dev/null
+++ b/dev-python/sleekxmpp/sleekxmpp-1.1.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+PYTHON_USE_WITH="xml"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit vcs-snapshot distutils
+
+DESCRIPTION="MIT licensed XMPP library for Python"
+HOMEPAGE="http://sleekxmpp.com/"
+SRC_URI="https://github.com/fritzy/SleekXMPP/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc examples"
+
+DEPEND="
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND="
+ dev-python/dnspython
+ dev-python/python-gnupg
+"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ make -C docs html
+ dohtml -r docs/_build/html/
+ fi
+ if use examples; then
+ dodoc -r examples
+ fi
+}
diff --git a/dev-python/sleekxmpp/sleekxmpp-9999.ebuild b/dev-python/sleekxmpp/sleekxmpp-9999.ebuild
new file mode 100644
index 0000000..6a9f518
--- /dev/null
+++ b/dev-python/sleekxmpp/sleekxmpp-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+PYTHON_USE_WITH="xml"
+SUPPORT_PYTHON_ABIS="1"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit vcs-snapshot distutils git-2
+
+DESCRIPTION="MIT licensed XMPP library for Python"
+HOMEPAGE="http://sleekxmpp.com/"
+EGIT_REPO_URI="git://github.com/fritzy/SleekXMPP.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="
+ dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND="
+ dev-python/dnspython3
+ dev-python/python-gnupg
+"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ make -C docs html
+ dohtml -r docs/_build/html/
+ fi
+ if use examples; then
+ dodoc -r examples
+ fi
+}