summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <smithdanea@gmail.com>2010-07-29 13:38:39 -0400
committerDane Smith <smithdanea@gmail.com>2010-07-29 13:38:39 -0400
commit094d0a8812f7d5cead8ee2afad8fda1e187fc354 (patch)
tree9a18514f44af9c4e808ee9575be8bb00fd20d373
parentNew ebuild for plugman (diff)
downloadsmithdanea-094d0a8812f7d5cead8ee2afad8fda1e187fc354.tar.gz
smithdanea-094d0a8812f7d5cead8ee2afad8fda1e187fc354.tar.bz2
smithdanea-094d0a8812f7d5cead8ee2afad8fda1e187fc354.zip
Testing ebuild for hostmap.
-rw-r--r--net-analyzer/hostmap/ChangeLog10
-rw-r--r--net-analyzer/hostmap/Manifest3
-rw-r--r--net-analyzer/hostmap/hostmap-0.2.2.ebuild27
3 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/hostmap/ChangeLog b/net-analyzer/hostmap/ChangeLog
new file mode 100644
index 0000000..cb58e02
--- /dev/null
+++ b/net-analyzer/hostmap/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-analyzer/hostmap
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*hostmap-0.2.2 (29 Jul 2010)
+
+ 29 Jul 2010; Dane Smith (c1pher) <smithdanea@gmail.com>
+ +hostmap-0.2.2.ebuild:
+ Inital ebuild for hostmap. Still testing.
+
diff --git a/net-analyzer/hostmap/Manifest b/net-analyzer/hostmap/Manifest
new file mode 100644
index 0000000..6deff4c
--- /dev/null
+++ b/net-analyzer/hostmap/Manifest
@@ -0,0 +1,3 @@
+DIST hostmap-0.2.2.tgz 416653 RMD160 df8c182ed3119b59066418b60fba5db6651d446c SHA1 8802297c338f6ca93b3a767765ae66cdf2c5d319 SHA256 90d8416b6b3fdb84dd7dab4bd08fca3a567c1011d60c71db5376afb35f072b1d
+EBUILD hostmap-0.2.2.ebuild 591 RMD160 5ac0d1bdf70c92352151e79bcf86c0bc97609b2d SHA1 a82b6d1a17aba3b4a97c4229e3cfc45e2932b103 SHA256 59ee2bffa6924ae3b3a280c2cfde73ce135b68a0b5e2ad38ad481e14f2f26370
+MISC ChangeLog 279 RMD160 aa41af405ceae0d0ab175523d8afe0e04ae22a42 SHA1 a76e9eac49d0f7ccc04fa28c76b7e185cffc0819 SHA256 8e7e9b1f2e49a4502441245a7d0b9a0d7c1ed106029804eb040800e6c31a7ab5
diff --git a/net-analyzer/hostmap/hostmap-0.2.2.ebuild b/net-analyzer/hostmap/hostmap-0.2.2.ebuild
new file mode 100644
index 0000000..97e51cd
--- /dev/null
+++ b/net-analyzer/hostmap/hostmap-0.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+USE_RUBY="ruby18"
+inherit ruby-fakegem
+
+DESCRIPTION="Automatic hostname and virtual hosts discovery tool written in Ruby"
+HOMEPAGE="http://hostmap.lonerunners.net/"
+SRC_URI="http://update.lonerunners.net/software/download/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="discovery dictionaries extra"
+RUBY_FAKEGEM_BINWRAP="hostmap.rb"
+
+ruby_add_rdepend "dev-ruby/net-dnsa
+ dev-ruby/plugman"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+