aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2016-05-13 00:31:44 +0100
committerStuart Shelton <stuart@shelton.me>2016-05-13 00:31:44 +0100
commitfc6edccc1c7f29d8edb5906333a9bfc3c3622181 (patch)
treee4f26ab5921f4ea3ba246c3dc611afcc7de2a0cc /sys-boot
parentAdd sys-devel/llvm-3.7.1-r2, sys-devel/llvm-3.8.0-r2, update sys-devel/llvm-3... (diff)
downloadsrcshelton-fc6edccc1c7f29d8edb5906333a9bfc3c3622181.tar.gz
srcshelton-fc6edccc1c7f29d8edb5906333a9bfc3c3622181.tar.bz2
srcshelton-fc6edccc1c7f29d8edb5906333a9bfc3c3622181.zip
Update sys-boot/raspberrypi-firmware-0.9999
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/raspberrypi-firmware/Manifest2
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-0.9999.ebuild18
2 files changed, 12 insertions, 8 deletions
diff --git a/sys-boot/raspberrypi-firmware/Manifest b/sys-boot/raspberrypi-firmware/Manifest
index 2339a153..6715d3f2 100644
--- a/sys-boot/raspberrypi-firmware/Manifest
+++ b/sys-boot/raspberrypi-firmware/Manifest
@@ -1,4 +1,4 @@
AUX raspberrypi-firmware-cmdline.txt 127 SHA256 a5ef22a89457706ab4c8cb974d72a9ac6910fa44b9f23b85ebe22c7af6774654 SHA512 238b238bd7d0ce62a65f17a1082165601444e5f105a4bf5539c8ee3aed42fe4c8bce02ca2562409cd00308e1699a6a35d7b9c70729ed22443e181cb12c89392d WHIRLPOOL 79f4f02e06e6835f5c04d11afb3949630d16a89cad609dfa99ef540cf0707e13b3de4958ecdf5d7727a15b98891f2e70b967d50b34b8cf3a6c2547df45103ccb
AUX raspberrypi-firmware-config.txt 25371 SHA256 1cf8ec9541c2ad7ce914b8aa0bff5cc62272888c01e4199bd93600f54d659b1a SHA512 1ebf10783b5f402160226f7d620fe70953920e6afc8d1e75a4676221729192a0819c7f579eaf885bbef9b7c013c42ca624fe2e32025304457cc6c8ec0b9e9f43 WHIRLPOOL 65b0aec4b02305c7377e4b980fa35aa2ff30e8384adb82d61f453297e14ff2884063f2bc8d4afcf1340c8bd5dbef4a0a7eb0be092f97d1601fe080832daeed76
AUX raspberrypi-firmware-envd 52 SHA256 514e767266ba32e81fa8fb58ee8f5b5ad9799963c2dd4761eb2c442122c240d3 SHA512 ce6aab6503cdf6f084cdf7b525ddf4ecdc19d10e439bd0b2f48f1beefcedd4d7eb8d5d203acc7b8b437ee1766653ba743124352c39f67bab6418db80e7b5215b WHIRLPOOL addc92da51a823b4f68dd25dc1bced57e496387ca3d8505523764189180b196c908ff9ff0ebfcc2a469dcfd4fb5cb361b302b12056f52729d5eecfd36498463d
-EBUILD raspberrypi-firmware-0.9999.ebuild 5453 SHA256 545da1eb5763d192f9f31cdac659658138ec3c5df1b77eed86244b6fb46d2611 SHA512 c0cfebf74f89673f85061bd95ed042e669dc4d3e91919dc79e106f1cdf84c8861187604ac9c452b90e8639127f4026d96125457d2755a608f2f75803d2c615f7 WHIRLPOOL 4cb842a3aa6cf8e3908dcd010a9f96de4bcafb02a9fb73285c0f7f4f20d20efe64299dd8dff41cbadcafe1d70dbabb8606e90652955a803f520b571cdfbf3b37
+EBUILD raspberrypi-firmware-0.9999.ebuild 5763 SHA256 508861769e397e9a6ef646f86596ed87a276d3b5d34dae75bbdfef26818eff63 SHA512 efe30ac6d32c58168f3bd9c31a88099395ce6039de02a751d22a95e2f8677f0cc9d164f7723648027444015ed8e97df587ccb218426af35559192636273dd864 WHIRLPOOL e26219a4f647b690ae58525fb9e75c937751ffffd87101d5c679264a41c9fb3c2a1a0b2f98eb11c63f9ffed2557050b2886369ba9ccff7d8e7ddf9377c89f94d
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0.9999.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0.9999.ebuild
index 7de3bd06..9ab790a1 100644
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0.9999.ebuild
+++ b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-0.9999.ebuild
@@ -62,6 +62,8 @@ pkg_setup() {
einfo "Checking mount-points ..."
[[ "${boot}" == "${boot// }" ]] || die "Invalid value '${boot}' for control variable 'RASPBERRYPI_BOOT'"
+ [[ "${boot:0:1}" == "/" ]] || die "Invalid value '${boot}' for control variable 'RASPBERRYPI_BOOT': Value must be absolute path"
+ boot="$( readlink -e "${boot}" )" || die "readlink failed: ${?}"
if [[ -z "${RASPBERRYPI_BOOT:-}" ]]; then
ewarn "This ebuild assumes that your FAT32 firmware/boot partition is"
@@ -153,7 +155,7 @@ src_install() {
esac
done
- insinto /boot
+ insinto "${boot}"
newins "${FILESDIR}"/${PN}-config.txt config.txt
newins "${FILESDIR}"/${PN}-cmdline.txt cmdline.txt
@@ -162,12 +164,14 @@ src_install() {
if [[ -n "${ver}" ]]; then
use rpi2 && newins extra/System7.map "System.map-${ver}-v7+"
use rpi1 && newins extra/System.map "System.map-${ver}+"
- einfo "You should create a symlink from /System.map to /boot/System.map"
- einfo "and from /boot/System.map to System.map-${ver}+ or System.map-${ver}-v7+,"
+ einfo "You should create a symlink from /System.map to ${boot}/System.map"
+ einfo "and from ${boot}/System.map to System.map-${ver}+ or System.map-${ver}-v7+,"
einfo "as appropriate."
fi
- newenvd "${FILESDIR}"/${PN}-envd 90${PN}
+ cp "${FILESDIR}"/"${PN}"-envd "${T}"/"${PN}"-envd
+ sed -i "s|/boot|${boot}|g" "${T}"/"${PN}"-envd
+ newenvd "${T}"/"${PN}"-envd "90${PN}"
}
pkg_preinst() {
@@ -177,8 +181,8 @@ pkg_preinst() {
#if [[ -e "${D}"/boot/cmdline.txt -a -e /boot/cmdline.txt ]] ; then
# msg+="/boot/cmdline.txt "
#fi
- if [ [-e "${D}"/boot/config.txt -a -e /boot/config.txt ]] ; then
- msg+="/boot/config.txt "
+ if [ [-e "${D}${boot}"/config.txt -a -e "${boot}"/config.txt ]] ; then
+ msg+="${boot}/config.txt "
fi
if [ -n "${msg}" ] ; then
msg="This package installs following files: ${msg}"
@@ -196,5 +200,5 @@ pkg_preinst() {
pkg_postinst() {
mount-boot_pkg_postinst
- einfo "Please customise your Raspberry Pi configuration by editing /boot/config.txt"
+ einfo "Please customise your Raspberry Pi configuration by editing ${boot}/config.txt"
}