summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd-units/systemd-units-9999.ebuild')
-rw-r--r--sys-apps/systemd-units/systemd-units-9999.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/sys-apps/systemd-units/systemd-units-9999.ebuild b/sys-apps/systemd-units/systemd-units-9999.ebuild
index 268e9e9..017a946 100644
--- a/sys-apps/systemd-units/systemd-units-9999.ebuild
+++ b/sys-apps/systemd-units/systemd-units-9999.ebuild
@@ -14,7 +14,7 @@ SRC_URI="basic? ( http://0pointer.de/public/systemd-units/sshd.service
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+basic +desktop server"
+IUSE="+basic +desktop server +ingnome3"
RDEPEND=""
DEPEND=""
@@ -34,5 +34,9 @@ src_install() {
if use desktop; then
systemd_dounit "${FILESDIR}"/services-desktop/*
+
+ if ! use ingnome3; then
+ rm -f "${D}/$(systemd_get_unitdir)"/gdm@.service
+ fi
fi
}