summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwbrana <wbrana@gmail.com>2012-11-21 16:49:31 +0100
committerwbrana <wbrana@gmail.com>2012-11-21 16:49:31 +0100
commit7370cd40daecd2043644e6dc58a9385896b4bddd (patch)
tree4e13b6bfafe1afe049cfc870d8675ed184177677
parentfix firefox-bin (diff)
downloadwbrana-7370cd40daecd2043644e6dc58a9385896b4bddd.tar.gz
wbrana-7370cd40daecd2043644e6dc58a9385896b4bddd.tar.bz2
wbrana-7370cd40daecd2043644e6dc58a9385896b4bddd.zip
[sys-apps/readahead] new ebuild
-rw-r--r--sys-apps/readahead/Manifest2
-rw-r--r--sys-apps/readahead/readahead-12.1.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/readahead/Manifest b/sys-apps/readahead/Manifest
new file mode 100644
index 0000000..dd2f90d
--- /dev/null
+++ b/sys-apps/readahead/Manifest
@@ -0,0 +1,2 @@
+DIST readahead-12.1.tar.xz 10636 SHA256 f74fa338fa6c8cd1d282163e7fd3417c740529f62b7f7ae86a42a373927e5d03 SHA512 f1022d61430b2c065d309c8ea1cfa517d8e920dc3b70f18564609e8b601ee90e98b5bfa771001e14422c9d88d8aee508def4274675ea45f6b5d5e5b2873e16cc WHIRLPOOL bfd5b62baaf33cd1a9f5805a4ee3cd03414f1ce452685cbfb843e97f6d7fc56169020b7fa56e0999f05a3c4101771c7806bb9954d4e8264a8ea63dd56310282f
+EBUILD readahead-12.1.ebuild 1046 SHA256 cd2a8f11929e0148a51a6873032f1f13b44c307a9c86a16360185966e173232d SHA512 b9291ba1fcab35625f12f4f141cf0d609200073af8f01f97732a5ab8b3e28d8b628c08cfc96b2b7b0170af02539d95a0c10b21802d787d8fbb629c10f8a3eac9 WHIRLPOOL a7267e2c2a18121a442cec69312abea5429256ef45a184d6f138dbee3f20083c7d623f4b9f9f71e70857a3ac1ebd1798212d6c3ac469a70cee7a5850c3d2daac
diff --git a/sys-apps/readahead/readahead-12.1.ebuild b/sys-apps/readahead/readahead-12.1.ebuild
new file mode 100644
index 0000000..2cbddde
--- /dev/null
+++ b/sys-apps/readahead/readahead-12.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+SCONS_MIN_VERSION="2.2"
+
+inherit scons-utils toolchain-funcs
+
+DESCRIPTION="ahead file reader for ext4 compatible filesystems"
+HOMEPAGE="http://sourceforge.net/projects/readahead/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ >=x11-libs/qt-core-4.8:4
+"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-4.6
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != "binary" ]]; then
+ local major=$(gcc-major-version)
+ local minor=$(gcc-minor-version)
+ if (( major < 4 || ( major == 4 && minor < 6 ) )); then
+ die "gcc 4.6 or newer is required"
+ fi
+ fi
+}
+
+src_configure() {
+ myesconsargs=(
+ env=1
+ final=1
+ $(use_scons debug)
+ )
+}
+
+src_compile() {
+ escons
+}
+
+src_install() {
+ escons prefix="${D}" install
+ newinitd init.d/readahead readahead
+}
+
+pkg_postinst() {
+ rc-config add readahead boot
+}
+
+pkg_prerm() {
+ rc-config delete readahead boot
+}