summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild')
-rw-r--r--x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild
index 41c6d32..0edf955 100644
--- a/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild
+++ b/x11-plugins/cairo-dock-plugins/cairo-dock-plugins-9999-r2.ebuild
@@ -4,6 +4,11 @@
EAPI="2"
+
+# The ebuild depends on CMAKE and also the BZR revision control system
+# which is used for pulling the source code from the LaunchPad repository
+inherit cmake-utils bzr
+
# Launchpad repository where "cairo-dock-plugins" lives:
EBZR_REPO_URI="lp:cairo-dock-plug-ins"
@@ -11,8 +16,6 @@ EBZR_REPO_URI="lp:cairo-dock-plug-ins"
# Or comment it out to choose the latest ("live") revision.
#EBZR_REVISION="2242"
-inherit cmake-utils bzr
-
DESCRIPTION="Official plugins for cairo-dock"
HOMEPAGE="https://launchpad.net/cairo-dock-plug-ins/"
# Next line is not needed because the BZR repository is specified further above
@@ -71,16 +74,6 @@ src_prepare() {
bzr_src_prepare
}
-# ==== These lines are from someone else's ebuild, with my notes...
-
-# Can't find out what the following line does (no Gentoo documentation on it?) and it seems to find the makefile and compile fine without it, so commenting it out.
-#MAKE_IN_SOURCE_BUILD=true
-
-# Actually, it looks like it is supposed to be CMAKE_IN_SOURCE_BUILD
-# http://devmanual.gentoo.org/eclass-reference/cmake-utils.eclass/index.html
-# But still not needed, so it is still commented out.
-#CMAKE_IN_SOURCE_BUILD=true
-
src_configure() {