summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/xmlm/xmlm-1.0.2.ebuild')
-rw-r--r--dev-ml/xmlm/xmlm-1.0.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/xmlm/xmlm-1.0.2.ebuild b/dev-ml/xmlm/xmlm-1.0.2.ebuild
new file mode 100644
index 0000000..662aa79
--- /dev/null
+++ b/dev-ml/xmlm/xmlm-1.0.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit findlib
+
+DESCRIPTION="Xmlm is an OCaml module providing streaming XML input/output"
+HOMEPAGE="http://erratique.ch/software/xmlm"
+SRC_URI="http://erratique.ch/software/xmlm/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc ocamlopt"
+
+DEPEND="${DEPEND}
+>=dev-lang/ocaml-3.10[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ./build module-byte
+
+ if use ocamlopt; then
+ ./build module-native
+ fi
+
+ if use doc; then
+ ./build doc
+ fi
+}
+
+src_install() {
+ export INSTALLDIR=${D}/`ocamlc -where`/xmlm
+
+ ./build install-byte
+ if use ocamlopt; then
+ ./build install
+ else
+ ./build install-byte
+ fi
+}