summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/joomla/joomla-1.6.4.ebuild')
-rw-r--r--www-apps/joomla/joomla-1.6.4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/www-apps/joomla/joomla-1.6.4.ebuild b/www-apps/joomla/joomla-1.6.4.ebuild
new file mode 100644
index 0000000..39cf6e6
--- /dev/null
+++ b/www-apps/joomla/joomla-1.6.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/joomla/joomla-1.5.22.ebuild,v 1.2 2010/11/05 12:05:05 fauli Exp $
+
+EAPI=2
+
+inherit webapp depend.php
+
+DESCRIPTION="Joomla is a powerful Open Source Content Management System."
+HOMEPAGE="http://www.joomla.org/"
+SRC_URI="http://joomlacode.org/gf/download/frsrelease/15063/65933/Joomla_${PV}-Stable-Full_Package.zip"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64"
+IUSE=""
+
+need_httpd_cgi
+need_php_httpd
+
+S="${WORKDIR}"
+
+DEPEND="${DEPEND}
+ app-arch/unzip"
+RDEPEND="dev-lang/php[json,mysql,zlib,xml]"
+
+src_install () {
+ webapp_src_preinst
+
+ dodoc installation/CHANGELOG installation/INSTALL README.txt
+
+ touch configuration.php
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ local files=" administrator/cache administrator/components
+ administrator/language administrator/language/en-GB
+ administrator/manifests/packages
+ administrator/modules administrator/templates cache components images
+ images/banners language language/en-GB media modules plugins
+ plugins/authentication plugins/content plugins/editors plugins/editors-xtd
+ plugins/search plugins/system plugins/user plugins tmp templates"
+
+ for file in ${files}; do
+ webapp_serverowned "${MY_HTDOCSDIR}"/${file}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/configuration.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/configuration.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_src_install
+}