summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-16 02:21:38 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-16 02:21:38 +0000
commit36ee1596230e342a4a6f1a3bc58bc163fa07d29a (patch)
treeb9c9190057524bdb821573af560966c83ea5e791
parentadd inherit eutils (diff)
downloadgentoo-2-36ee1596230e342a4a6f1a3bc58bc163fa07d29a.tar.gz
gentoo-2-36ee1596230e342a4a6f1a3bc58bc163fa07d29a.tar.bz2
gentoo-2-36ee1596230e342a4a6f1a3bc58bc163fa07d29a.zip
add inherit eutils
-rw-r--r--dev-db/mysql/mysql-3.23.57-r1.ebuild17
-rw-r--r--dev-db/postgresql/postgresql-7.3.4-r1.ebuild21
-rw-r--r--dev-db/sqlgui/sqlgui-0.4.ebuild19
-rw-r--r--dev-db/sqlgui/sqlgui-0.5.ebuild23
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.2.ebuild18
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild33
-rw-r--r--dev-java/ant-optional/ant-optional-1.6.0-r2.ebuild22
7 files changed, 68 insertions, 85 deletions
diff --git a/dev-db/mysql/mysql-3.23.57-r1.ebuild b/dev-db/mysql/mysql-3.23.57-r1.ebuild
index 979ba470f84a..a3cb3d3e450a 100644
--- a/dev-db/mysql/mysql-3.23.57-r1.ebuild
+++ b/dev-db/mysql/mysql-3.23.57-r1.ebuild
@@ -1,12 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.57-r1.ebuild,v 1.3 2004/02/22 07:34:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.57-r1.ebuild,v 1.4 2004/04/16 02:17:17 vapier Exp $
-# bug #11681; get b0rked code when using -march=k6 with this package.
-inherit flag-o-matic
-replace-flags "-march=k6-3" "-march=i586"
-replace-flags "-march=k6-2" "-march=i586"
-replace-flags "-march=k6" "-march=i586"
+inherit flag-o-matic eutils
SVER=${PV%.*}
#normal releases:
@@ -21,8 +17,8 @@ SRC_URI="ftp://ftp.sunet.se/pub/unix/databases/relational/mysql/Downloads/${SDIR
LICENSE="GPL-2"
SLOT="0"
-IUSE="static readline innodb berkdb tcpd ssl debug"
KEYWORDS="x86 ~sparc ~alpha ~hppa"
+IUSE="static readline innodb berkdb tcpd ssl debug"
DEPEND="readline? ( >=sys-libs/readline-4.1 )
tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
@@ -30,7 +26,6 @@ DEPEND="readline? ( >=sys-libs/readline-4.1 )
>=sys-libs/zlib-1.1.3
dev-lang/perl
sys-apps/procps"
-
PDEPEND="perl? ( dev-perl/DBI dev-perl/DBD-mysql )"
src_unpack() {
@@ -49,6 +44,9 @@ src_unpack() {
}
src_compile() {
+ # bug #11681; get b0rked code when using -march=k6 with this package.
+ replace-cpu-flags i586 k6 k6-2 k6-3
+
local myconf
# The following fix is due to a bug with bdb on sparc's. See:
# http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
@@ -134,8 +132,7 @@ src_install() {
rm -f ${D}/usr/bin/mysql_setpermission
fi
- dodoc README COPYING COPYING.LIB MIRRORS \
- Docs/{manual.ps,manual.txt}
+ dodoc README MIRRORS Docs/{manual.ps,manual.txt}
dohtml -r Docs/*
docinto conf-samples
dodoc support-files/my-*.cnf
diff --git a/dev-db/postgresql/postgresql-7.3.4-r1.ebuild b/dev-db/postgresql/postgresql-7.3.4-r1.ebuild
index a3badb91bdcd..043864d79a06 100644
--- a/dev-db/postgresql/postgresql-7.3.4-r1.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.4-r1.ebuild
@@ -1,13 +1,11 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.4-r1.ebuild,v 1.8 2004/04/06 02:59:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.4-r1.ebuild,v 1.9 2004/04/16 02:18:38 vapier Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
-DESCRIPTION="sophisticated Object-Relational DBMS"
-
-RESTRICT="nomirror"
P_HIERPG="hier-Pg7.3-0.3"
+DESCRIPTION="sophisticated Object-Relational DBMS"
HOMEPAGE="http://www.postgresql.org/ http://gppl.terminal.ru/index.eng.html"
SRC_URI="mirror://postgresql/src/${PV}/${P}.tar.gz
pg-hier? ( http://gppl.terminal.ru/${P_HIERPG}.tar.gz )"
@@ -16,6 +14,7 @@ LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="x86 ppc sparc alpha amd64 hppa"
IUSE="ssl nls java python tcltk perl libg++ pam readline zlib pg-hier"
+RESTRICT="nomirror"
DEPEND="virtual/glibc
sys-devel/autoconf
@@ -80,7 +79,7 @@ check_java_config() {
src_unpack() {
unpack ${A} || die
- if [ "`use pg-hier`" ]; then
+ if use pg-hier ; then
cd ${WORKDIR} || die
mv readme.html README-${P_HIERPG}.html || die
cd ${S} || die
@@ -92,7 +91,7 @@ src_unpack() {
src_compile() {
filter-flags -ffast-math
- if [ "`use java`" -a ! "`use amd64`" -a ! "`use hppa`" ]; then
+ if use java && ! use amd64 && ! use hppa ; then
check_java_config
fi
@@ -100,7 +99,7 @@ src_compile() {
use tcltk && myconf="--with-tcl"
use python && use ppc || myconf="$myconf --with-python"
use perl && myconf="$myconf --with-perl"
- if [ "`use java`" -a ! "`use amd64`" -a ! "`use hppa`" ]; then
+ if use java && ! use amd64 && ! use hppa ; then
myconf="$myconf --with-java"
fi
use ssl && myconf="$myconf --with-openssl"
@@ -133,7 +132,7 @@ src_compile() {
src_install() {
addwrite "/usr/share/man/man3/Pg.3pm"
- if [ "`use perl`" ]
+ if use perl
then
mv ${S}/src/pl/plperl/Makefile ${S}/src/pl/plperl/Makefile_orig
sed -e "s:(INST_DYNAMIC) /usr/lib:(INST_DYNAMIC) ${D}/usr/lib:" \
@@ -148,7 +147,7 @@ src_install() {
cd ${S}/contrib
make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
cd ${S}
- if [ "`use pg-hier`" ]; then
+ if use pg-hier ; then
dodoc ${WORKDIR}/README-${P_HIERPG}.html
fi
dodoc COPYRIGHT HISTORY INSTALL README register.txt
@@ -165,7 +164,7 @@ src_install() {
rm -rf ${D}/usr/doc ${D}/mnt
exeinto /usr/bin
- if [ "`use java`" -a ! "`use amd64`" -a ! "`use hppa`" ]; then
+ if use java && ! use amd64 && ! use hppa ; then
dojar ${D}/usr/share/postgresql/java/postgresql.jar
rm ${D}/usr/share/postgresql/java/postgresql.jar
fi
diff --git a/dev-db/sqlgui/sqlgui-0.4.ebuild b/dev-db/sqlgui/sqlgui-0.4.ebuild
index 0c2dea9cdb8e..920c88ed65de 100644
--- a/dev-db/sqlgui/sqlgui-0.4.ebuild
+++ b/dev-db/sqlgui/sqlgui-0.4.ebuild
@@ -1,33 +1,32 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlgui/sqlgui-0.4.ebuild,v 1.8 2004/03/14 17:22:44 mr_bones_ Exp $
-
-inherit kde
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlgui/sqlgui-0.4.ebuild,v 1.9 2004/04/16 02:19:11 vapier Exp $
+inherit kde eutils
need-kde 3
-newdepend ">=dev-db/mysql-3.23.38
- >=dev-db/sqlguipart-${PV}"
-
MY_P="${PN}-${PV}.0"
DESCRIPTION="GUI for the dev-db/sqlguipart, administration tool for a mysql db"
-SRC_URI="http://www.sqlgui.de/download/${MY_P}.tar.gz"
HOMEPAGE="http://www.sqlgui.de/"
+SRC_URI="http://www.sqlgui.de/download/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
+
+DEPEND=">=dev-db/mysql-3.23.38
+ >=dev-db/sqlguipart-${PV}"
+
S=${WORKDIR}/${MY_P}/${P}
myconf="$myconf --with-extra-includes=/usr/include/mysql"
src_unpack() {
-
cd ${WORKDIR}
unpack ${A}
cd ${MY_P}
- tar -xvzpf ${P}.tar.gz || die
+ tar -xzpf ${P}.tar.gz || die
cd ${S}
epatch ${FILESDIR}/${P}-gcc3.diff
}
diff --git a/dev-db/sqlgui/sqlgui-0.5.ebuild b/dev-db/sqlgui/sqlgui-0.5.ebuild
index 055b2e721e18..600f346a31e2 100644
--- a/dev-db/sqlgui/sqlgui-0.5.ebuild
+++ b/dev-db/sqlgui/sqlgui-0.5.ebuild
@@ -1,31 +1,22 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlgui/sqlgui-0.5.ebuild,v 1.3 2004/03/14 17:22:44 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlgui/sqlgui-0.5.ebuild,v 1.4 2004/04/16 02:19:43 vapier Exp $
inherit kde
-
need-kde 3
-newdepend ">=dev-db/mysql-3.23.38
- >=dev-db/sqlguipart-${PV}"
-
MY_P="${PN}-${PV}.0"
DESCRIPTION="GUI for the dev-db/sqlguipart, administration tool for a mysql db"
-SRC_URI="http://www.sqlgui.de/download/${MY_P}.tar.gz"
HOMEPAGE="http://www.sqlgui.de/"
+SRC_URI="http://www.sqlgui.de/download/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
-S=${WORKDIR}/${MY_P}
-
-myconf="$myconf --with-extra-includes=/usr/include/mysql"
+DEPEND=">=dev-db/mysql-3.23.38
+ >=dev-db/sqlguipart-${PV}"
-src_unpack() {
+S=${WORKDIR}/${MY_P}
- cd ${WORKDIR}
- unpack ${A}
- cd ${S}
-# epatch ${FILESDIR}/${P}-gcc3.diff
-}
+myconf="$myconf --with-extra-includes=/usr/include/mysql"
diff --git a/dev-db/unixODBC/unixODBC-2.2.2.ebuild b/dev-db/unixODBC/unixODBC-2.2.2.ebuild
index 8dccc9ddd7ab..55c829b715b9 100644
--- a/dev-db/unixODBC/unixODBC-2.2.2.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.2.ebuild,v 1.14 2004/03/23 09:15:10 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.2.ebuild,v 1.15 2004/04/16 02:20:14 vapier Exp $
+
+inherit eutils
DESCRIPTION="ODBC Interface for Linux"
HOMEPAGE="http://www.unixodbc.org/"
@@ -28,17 +30,17 @@ src_unpack() {
src_compile() {
local myconf
-
- if use qt; then
+ if use qt ; then
myconf="--enable-gui=yes"
else
myconf="--enable-gui=no"
fi
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc/unixODBC \
- ${myconf} || die
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
make || die
}
@@ -46,7 +48,7 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
- dodoc AUTHORS COPYING ChangeLog NEWS README*
+ dodoc AUTHORS ChangeLog NEWS README*
find doc/ -name "Makefile*" -exec rm '{}' \;
dohtml doc/*
prepalldocs
diff --git a/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild b/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild
index 7dd340e2136e..8bff5b48c165 100644
--- a/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild,v 1.4 2004/03/23 09:15:10 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.6-r1.ebuild,v 1.5 2004/04/16 02:21:04 vapier Exp $
+
+inherit eutils
DESCRIPTION="ODBC Interface for Linux"
HOMEPAGE="http://www.unixodbc.org/"
@@ -22,7 +24,7 @@ src_unpack() {
unpack ${P}.tar.gz
cd ${S}
-# braindead check in configure fails - hack approach
+ # braindead check in configure fails - hack approach
epatch ${FILESDIR}/${P}-configure.in.patch
autoconf || die "autoconf failed"
@@ -31,27 +33,28 @@ src_unpack() {
src_compile() {
local myconf
- if [ "`use qt`" ]
- then
+ if use qt ; then
myconf="--enable-gui=yes"
else
myconf="--enable-gui=no"
fi
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc/unixODBC \
- ${myconf} || die
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
make || die
- if [ "`use gnome`" ]
+ if use gnome
then
cd gODBCConfig
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc/unixODBC \
- ${myconf} || die
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
+ ${myconf} || die
# not sure why these symlinks are needed. busted configure, i guess...
ln -s ../depcomp .
@@ -64,14 +67,14 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
- if [ "`use gnome`" ]
+ if use gnome
then
cd gODBCConfig
make DESTDIR=${D} install || die
cd ..
fi
- dodoc AUTHORS COPYING ChangeLog NEWS README*
+ dodoc AUTHORS ChangeLog NEWS README*
find doc/ -name "Makefile*" -exec rm '{}' \;
dohtml doc/*
prepalldocs
diff --git a/dev-java/ant-optional/ant-optional-1.6.0-r2.ebuild b/dev-java/ant-optional/ant-optional-1.6.0-r2.ebuild
index dc41531a3f12..4c8621350c24 100644
--- a/dev-java/ant-optional/ant-optional-1.6.0-r2.ebuild
+++ b/dev-java/ant-optional/ant-optional-1.6.0-r2.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-optional/ant-optional-1.6.0-r2.ebuild,v 1.6 2004/03/11 02:47:52 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-optional/ant-optional-1.6.0-r2.ebuild,v 1.7 2004/04/16 02:21:38 vapier Exp $
-inherit java-pkg
+inherit java-pkg eutils
-IUSE="doc antlr bcel bsh javamail jdepend jsch junit jython log4j oro regexp rhino xalan xerces"
-
-S="${WORKDIR}/apache-ant-${PV}"
DESCRIPTION="Apache ANT Optional Tasks Jar Files"
-SRC_URI="mirror://apache/ant/source/apache-ant-${PV}-src.tar.bz2"
HOMEPAGE="http://ant.apache.org"
+SRC_URI="mirror://apache/ant/source/apache-ant-${PV}-src.tar.bz2"
+
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="-* ~x86"
+IUSE="doc antlr bcel bsh javamail jdepend jsch junit jython log4j oro regexp rhino xalan xerces"
+
DEPEND="=dev-java/ant-1.6.0-r2
>=dev-java/java-config-1.2
log4j? ( >=dev-java/log4j-1.2.8 )
@@ -32,16 +32,8 @@ DEPEND="=dev-java/ant-1.6.0-r2
regexp? ( >=dev-java/regexp-1.3 )
jython? ( >=dev-java/jython-2.1 )
javamail? ( >=dev-java/javamail-1.3 )"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- # Patch build.sh to die with non-zero exit code in case of errors.
- # This patch may be useful for all ant versions.
-# epatch ${FILESDIR}/build.sh-exit-fix.patch.gz
-}
+S="${WORKDIR}/apache-ant-${PV}"
src_compile() {