summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn P. Davis <zhen@gentoo.org>2002-11-21 01:39:00 +0000
committerJohn P. Davis <zhen@gentoo.org>2002-11-21 01:39:00 +0000
commit45f06189b1bb2f0f880d6e10e64f9166cc1bac65 (patch)
tree35575ba1685094ae71e24cbc1cafcc9b98503d92 /app-editors/vim
parentversion bump (diff)
downloadgentoo-2-45f06189b1bb2f0f880d6e10e64f9166cc1bac65.tar.gz
gentoo-2-45f06189b1bb2f0f880d6e10e64f9166cc1bac65.tar.bz2
gentoo-2-45f06189b1bb2f0f880d6e10e64f9166cc1bac65.zip
added UTF-8 compatibility
Diffstat (limited to 'app-editors/vim')
-rw-r--r--app-editors/vim/files/digest-vim-6.1-r172
-rw-r--r--app-editors/vim/vim-6.1-r17.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/app-editors/vim/files/digest-vim-6.1-r17 b/app-editors/vim/files/digest-vim-6.1-r17
new file mode 100644
index 000000000000..63796185e7f4
--- /dev/null
+++ b/app-editors/vim/files/digest-vim-6.1-r17
@@ -0,0 +1,2 @@
+MD5 7fd0f915adc7c0dab89772884268b030 vim-6.1.tar.bz2 2890049
+MD5 80747ac21d83777aeefb714f7a385b11 vimpatch-1-245.tar.bz2 191362
diff --git a/app-editors/vim/vim-6.1-r17.ebuild b/app-editors/vim/vim-6.1-r17.ebuild
new file mode 100644
index 000000000000..0e1e6fc25825
--- /dev/null
+++ b/app-editors/vim/vim-6.1-r17.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.1-r17.ebuild,v 1.1 2002/11/21 01:39:00 zhen Exp $
+
+inherit vim
+
+DESCRIPTION="Vi IMproved!"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+DEPEND="app-editors/vim-core
+ sys-libs/libtermcap-compat
+ dev-util/cscope
+ >=sys-libs/ncurses-5.2-r2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
+# tcltk? ( dev-lang/tcl )"
+
+src_compile() {
+ local myconf
+ myconf="--without-x --with-features=big --enable-multibyte"
+ use nls && myconf="$myconf --enable-multibyte"
+ use nls || myconf="$myconf --disable-nls"
+ use perl && myconf="$myconf --enable-perlinterp"
+ use python && myconf="$myconf --enable-pythoninterp"
+ use ruby && myconf="$myconf --enable-rubyinterp"
+
+# tclinterp is BROKEN. See note above DEPEND=
+# use tcltk && myconf="$myconf --enable-tclinterp"
+
+# Added back gpm for temporary will remove if necessary, I think that I have
+# fixed most of gpm so it should be fine.
+ use gpm || myconf="$myconf --disable-gpm"
+
+ # This should fix a sandbox violation.
+ addwrite "${SSH_TTY}"
+
+ #
+ # Build a nogui version, this will install as /usr/bin/vim
+ #
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
+ --with-features=huge --with-cscope $myconf \
+ --enable-gui=no \
+ || die "vim configure failed"
+ # Parallel make does not work
+ make || die "vim make failed"
+}
+
+src_install() {
+ dobin src/vim
+ ln -s vim ${D}/usr/bin/vimdiff
+ # Default vimrc
+ insinto /usr/share/vim
+ doins ${FILESDIR}/vimrc
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "gvim has now a seperate ebuild, 'emerge gvim' will install gvim"
+}