summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-15 23:35:33 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-15 23:35:33 +0000
commit4620efd183a61220f0e8d0df7bdc37ed3b1a56f2 (patch)
tree066df00ac7dbc9e192ce8509ca7949f60dab01cd /app-emulation
parentFixed mplayer-1.0_pre5-r3's message about not using custom CFLAGS. Put in th... (diff)
downloadgentoo-2-4620efd183a61220f0e8d0df7bdc37ed3b1a56f2.tar.gz
gentoo-2-4620efd183a61220f0e8d0df7bdc37ed3b1a56f2.tar.bz2
gentoo-2-4620efd183a61220f0e8d0df7bdc37ed3b1a56f2.zip
amd64 multilib check #85423
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/wine-20050211.ebuild12
-rw-r--r--app-emulation/wine/wine-20050310.ebuild12
2 files changed, 22 insertions, 2 deletions
diff --git a/app-emulation/wine/wine-20050211.ebuild b/app-emulation/wine/wine-20050211.ebuild
index 8286871a0651..976fbb32b757 100644
--- a/app-emulation/wine/wine-20050211.ebuild
+++ b/app-emulation/wine/wine-20050211.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.3 2005/03/08 16:49:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.4 2005/03/15 23:35:33 vapier Exp $
inherit eutils flag-o-matic
@@ -36,6 +36,16 @@ DEPEND="${RDEPEND}
doc? ( app-text/docbook-sgml-utils app-text/jadetex )
sys-devel/flex"
+pkg_setup() {
+ if use amd64 && ! has_m32; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
+ fi
+}
+
src_unpack() {
unpack Wine-${PV}.tar.gz
cd "${S}"
diff --git a/app-emulation/wine/wine-20050310.ebuild b/app-emulation/wine/wine-20050310.ebuild
index 542ccabbc1d4..f30a9636abb8 100644
--- a/app-emulation/wine/wine-20050310.ebuild
+++ b/app-emulation/wine/wine-20050310.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310.ebuild,v 1.1 2005/03/13 11:00:04 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310.ebuild,v 1.2 2005/03/15 23:35:33 vapier Exp $
inherit eutils flag-o-matic
@@ -36,6 +36,16 @@ DEPEND="${RDEPEND}
doc? ( app-text/docbook-sgml-utils app-text/jadetex )
sys-devel/flex"
+pkg_setup() {
+ if use amd64 && ! has_m32; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
+ fi
+}
+
src_unpack() {
unpack Wine-${PV}.tar.gz
cd "${S}"