summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-05-17 13:30:15 +0000
committerAchim Gottinger <achim@gentoo.org>2001-05-17 13:30:15 +0000
commit9be3c6a343e605bfa03f46ebbb061b27adec3c41 (patch)
treede47845ddbc13a29598d2aa117fda6c1b566c0da /app-office
parentSome minor dependenice fixes (diff)
downloadgentoo-2-9be3c6a343e605bfa03f46ebbb061b27adec3c41.tar.gz
gentoo-2-9be3c6a343e605bfa03f46ebbb061b27adec3c41.tar.bz2
gentoo-2-9be3c6a343e605bfa03f46ebbb061b27adec3c41.zip
*** empty log message ***
Diffstat (limited to 'app-office')
-rw-r--r--app-office/gnumeric/files/digest-gnumeric-0.64-r1 (renamed from app-office/gnumeric/files/digest-gnumeric-0.64)0
-rw-r--r--app-office/gnumeric/gnumeric-0.64-r1.ebuild51
2 files changed, 51 insertions, 0 deletions
diff --git a/app-office/gnumeric/files/digest-gnumeric-0.64 b/app-office/gnumeric/files/digest-gnumeric-0.64-r1
index b478595faf00..b478595faf00 100644
--- a/app-office/gnumeric/files/digest-gnumeric-0.64
+++ b/app-office/gnumeric/files/digest-gnumeric-0.64-r1
diff --git a/app-office/gnumeric/gnumeric-0.64-r1.ebuild b/app-office/gnumeric/gnumeric-0.64-r1.ebuild
new file mode 100644
index 000000000000..af36f7fce3a9
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-0.64-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/gnumeric/gnumeric-0.64-r1.ebuild,v 1.1 2001/05/17 13:29:30 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gnumeric"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnumeric/"${A}
+HOMEPAGE="http://www.gnome.org/gnome-office/gnumeric.shtml"
+
+DEPEND=">=sys-devel/perl-5
+ >=dev-lang/python-2.0
+ >=gnome-base/gal-0.3.0
+ >=gnome-libs/gb-0.0.17
+ >=gnome-libs/libole2-0.1.7
+ bonobo? ( >=gnome-base/bonobo-0.28
+ >=gnome-libs/libgda-0.2.0 ) "
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:"%d,:"%d",:' configure.orig > configure
+}
+
+src_compile() {
+ cd ${S}
+ local myconf
+ if [ "`use bonobo`" ]
+ then
+ myconf="--with-bonobo"
+ fi
+ LDFLAGS="-L/opt/gnome/lib -lunicode" try ./configure --host=${CHOST} --prefix=/opt/gnome \
+ ${myconf} --with-gb
+ cd ${S}
+ try make
+}
+
+src_install() {
+ cd ${S}
+ try make prefix=${D}/opt/gnome PREFIX=${D}/usr install
+ dodoc AUTHORS COPYING *ChangeLog HACKING NEWS README TODO
+
+}
+
+
+
+
+
+