summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-07-08 15:50:20 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-07-08 15:50:20 +0000
commit76351c4060ae6a59c1ed16064053cde53d86e714 (patch)
tree5765b57ffcdf4f9bb193c4694170f0425b345477 /app-shells
parentlibpng-1.2.4 masked (diff)
downloadgentoo-2-76351c4060ae6a59c1ed16064053cde53d86e714.tar.gz
gentoo-2-76351c4060ae6a59c1ed16064053cde53d86e714.tar.bz2
gentoo-2-76351c4060ae6a59c1ed16064053cde53d86e714.zip
Closing bug #4669
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/psh/ChangeLog8
-rw-r--r--app-shells/psh/files/digest-psh-0.009-r21
-rw-r--r--app-shells/psh/psh-0.009-r1.ebuild4
-rw-r--r--app-shells/psh/psh-0.009-r2.ebuild38
4 files changed, 49 insertions, 2 deletions
diff --git a/app-shells/psh/ChangeLog b/app-shells/psh/ChangeLog
index 3c4a0faa9611..9552b515a84c 100644
--- a/app-shells/psh/ChangeLog
+++ b/app-shells/psh/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/psh
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/ChangeLog,v 1.1 2002/02/01 21:53:09 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/ChangeLog,v 1.2 2002/07/08 15:50:20 aliz Exp $
+
+*psh-0.009-r2 (8 Jul 2002)
+
+ 8 Jul 2002; Daniel Ahlberg <aliz@gentoo.org> psh-0.009-r2.ebuild files/digest-psh-0.009-r2:
+
+ Fixes bug #4669.
*psh-0.009-r1 (1 Feb 2002)
diff --git a/app-shells/psh/files/digest-psh-0.009-r2 b/app-shells/psh/files/digest-psh-0.009-r2
new file mode 100644
index 000000000000..44b2887f9938
--- /dev/null
+++ b/app-shells/psh/files/digest-psh-0.009-r2
@@ -0,0 +1 @@
+MD5 a6d9dd7dc80ceb7ac63203bda7976622 psh-0.009.tar.gz 96704
diff --git a/app-shells/psh/psh-0.009-r1.ebuild b/app-shells/psh/psh-0.009-r1.ebuild
index 5110e761ff76..73aa89a961f8 100644
--- a/app-shells/psh/psh-0.009-r1.ebuild
+++ b/app-shells/psh/psh-0.009-r1.ebuild
@@ -1,13 +1,15 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/psh-0.009-r1.ebuild,v 1.2 2002/07/07 12:00:29 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/psh-0.009-r1.ebuild,v 1.3 2002/07/08 15:50:20 aliz Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
SRC_URI="http://www.focusresearch.com/gregor/psh/${P}.tar.gz"
HOMEPAGE="http://www.focusresearch.com/gregor/psh/"
LICENSE="Artistic | GPL-2"
+KEYWORDS="x86"
+SLOT="0"
DEPEND=">=sys-devel/perl-5"
diff --git a/app-shells/psh/psh-0.009-r2.ebuild b/app-shells/psh/psh-0.009-r2.ebuild
new file mode 100644
index 000000000000..3aaef0aa46d3
--- /dev/null
+++ b/app-shells/psh/psh-0.009-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-shells/psh/psh-0.009-r2.ebuild,v 1.1 2002/07/08 15:50:20 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Combines the interactive nature of a Unix shell with the power of Perl"
+SRC_URI="http://www.focusresearch.com/gregor/psh/${P}.tar.gz"
+HOMEPAGE="http://www.focusresearch.com/gregor/psh/"
+LICENSE="Artistic | GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND=">=sys-devel/perl-5"
+
+src_compile() {
+ perl Makefile.PL
+
+ make || die
+}
+
+src_install() {
+ make PREFIX=${D}/usr \
+ prefix=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ install || die
+
+ dodoc COPYRIGHT HACKING MANIFEST README* RELEASE TODO
+ dodoc examples/complete-examples
+}
+
+
+
+
+
+
+
+