summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-07-16 12:06:16 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-07-16 12:06:16 +0000
commit0dc7fa4f17385657acfef43d948c8dfee354533d (patch)
tree61c6ba9e038b29e686a429734220d1709597b4ab /dev-java
parentUpdate LICENSE to include the OSGi Specification 2.0 license and introduce fe... (diff)
downloadgentoo-2-0dc7fa4f17385657acfef43d948c8dfee354533d.tar.gz
gentoo-2-0dc7fa4f17385657acfef43d948c8dfee354533d.tar.bz2
gentoo-2-0dc7fa4f17385657acfef43d948c8dfee354533d.zip
Update LICENSE to include the OSGi Specification 2.0 license and introduce fetch restriction as the license needs to be explicitly accepted (except for osgi-foundation) to obtain the downloads.
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/osgi-core-api/ChangeLog8
-rw-r--r--dev-java/osgi-core-api/osgi-core-api-4.3.ebuild18
-rw-r--r--dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild14
3 files changed, 33 insertions, 7 deletions
diff --git a/dev-java/osgi-core-api/ChangeLog b/dev-java/osgi-core-api/ChangeLog
index 48b134e394c3..ec311af8d2a6 100644
--- a/dev-java/osgi-core-api/ChangeLog
+++ b/dev-java/osgi-core-api/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/osgi-core-api
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/osgi-core-api/ChangeLog,v 1.6 2013/03/25 20:47:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/osgi-core-api/ChangeLog,v 1.7 2013/07/16 12:06:16 tomwij Exp $
+
+ 16 Jul 2013; Tom Wijsman <TomWij@gentoo.org> osgi-core-api-4.3.ebuild,
+ osgi-core-api-5.0.0.ebuild:
+ Update LICENSE to include the OSGi Specification 2.0 license and introduce
+ fetch restriction as the license needs to be explicitly accepted (except for
+ osgi-foundation) to obtain the downloads.
25 Mar 2013; Agostino Sarubbo <ago@gentoo.org> osgi-core-api-5.0.0.ebuild:
Stable for x86, wrt bug #456528
diff --git a/dev-java/osgi-core-api/osgi-core-api-4.3.ebuild b/dev-java/osgi-core-api/osgi-core-api-4.3.ebuild
index 113f7a5ec3a7..1a320ee060bc 100644
--- a/dev-java/osgi-core-api/osgi-core-api-4.3.ebuild
+++ b/dev-java/osgi-core-api/osgi-core-api-4.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/osgi-core-api/osgi-core-api-4.3.ebuild,v 1.3 2012/05/09 17:09:40 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/osgi-core-api/osgi-core-api-4.3.ebuild,v 1.4 2013/07/16 12:06:16 tomwij Exp $
EAPI=4
@@ -10,13 +10,15 @@ inherit java-pkg-2 java-pkg-simple
DESCRIPTION="OSGi Service Platform Core API (Companion Code)"
HOMEPAGE="http://www.osgi.org/Specifications/HomePage"
-SRC_URI="http://www.osgi.org/download/r4v${PV//./}/osgi.core.jar -> ${P}-all.zip"
+SRC_URI="http://www.osgi.org/download/r4v${PV//./}/osgi.core-${PV}.0.jar -> ${P}-all.zip"
-LICENSE="Apache-2.0"
+LICENSE="Apache-2.0 OSGi-Specification-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
+RESTRICT="bindist fetch"
+
RDEPEND="
>=virtual/jre-1.5"
DEPEND="
@@ -25,6 +27,14 @@ DEPEND="
JAVA_SRC_DIR="OSGI-OPT/src"
+pkg_nofetch() {
+ einfo "Please download osgi.core-${PV}.jar from"
+ einfo " http://www.osgi.org/Download/Release4V43"
+ einfo "which you can find listed as"
+ einfo " OSGi Service Platform Release 4 Version 4.3 Core Companion Code 4.3.0"
+ einfo "after accepting the license."
+}
+
java_prepare() {
rm -r org || die
}
diff --git a/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild b/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild
index 0ad3af3fd757..7c63b9377c7e 100644
--- a/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild
+++ b/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild,v 1.3 2013/03/25 20:47:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/osgi-core-api/osgi-core-api-5.0.0.ebuild,v 1.4 2013/07/16 12:06:16 tomwij Exp $
EAPI=4
@@ -12,11 +12,13 @@ DESCRIPTION="OSGi Service Platform Core API (Companion Code)"
HOMEPAGE="http://www.osgi.org/Specifications/HomePage"
SRC_URI="http://www.osgi.org/download/r5/osgi.core-${PV}.jar"
-LICENSE="Apache-2.0"
+LICENSE="Apache-2.0 OSGi-Specification-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
+RESTRICT="bindist fetch"
+
RDEPEND="
>=virtual/jre-1.5"
DEPEND="
@@ -25,6 +27,14 @@ DEPEND="
JAVA_SRC_DIR="OSGI-OPT/src"
+pkg_nofetch() {
+ einfo "Please download osgi.core-${PV}.jar from"
+ einfo " http://www.osgi.org/Download/Release5"
+ einfo "which you can find listed as"
+ einfo " OSGi Core Release 5 Companion Code"
+ einfo "after accepting the license."
+}
+
java_prepare() {
rm -r org || die
}