summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2007-12-23 21:27:07 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2007-12-23 21:27:07 +0000
commit352c6686f7916a8256239fe0ebc48a54c7bf581e (patch)
tree6704785a501a11765268e12ce861d8ed10d50835 /dev-util/bouml/bouml-3.4.ebuild
parentversion bump (diff)
downloadgentoo-2-352c6686f7916a8256239fe0ebc48a54c7bf581e.tar.gz
gentoo-2-352c6686f7916a8256239fe0ebc48a54c7bf581e.tar.bz2
gentoo-2-352c6686f7916a8256239fe0ebc48a54c7bf581e.zip
Version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-util/bouml/bouml-3.4.ebuild')
-rw-r--r--dev-util/bouml/bouml-3.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/bouml/bouml-3.4.ebuild b/dev-util/bouml/bouml-3.4.ebuild
new file mode 100644
index 000000000000..a5415e575acf
--- /dev/null
+++ b/dev-util/bouml/bouml-3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-3.4.ebuild,v 1.1 2007/12/23 21:27:06 ferdy Exp $
+
+inherit multilib qt3
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool with code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(qt_min_version 3)"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ find src/ genplugouts/ -type f -name "*.pro" | while read file; do
+ local subdir="${file%/*}"
+ eqmake3 "${file}" -o "${subdir}"/Makefile
+ emake -C "${subdir}" || die "emake failed in ${subdir}"
+ done
+}
+
+src_install() {
+ emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install \
+ || die "emake install failed"
+}