summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2010-06-28 14:07:54 +0000
committerFabio Erculiani <lxnay@gentoo.org>2010-06-28 14:07:54 +0000
commit0c2301c8eb318bed8407aa5e54c8b2942850d4d2 (patch)
tree11a05ad9cef193862050a7a956c9cf1e07bab41e /dev-util/molecule
parentstable x86, bug 325425 (diff)
downloadgentoo-2-0c2301c8eb318bed8407aa5e54c8b2942850d4d2.tar.gz
gentoo-2-0c2301c8eb318bed8407aa5e54c8b2942850d4d2.tar.bz2
gentoo-2-0c2301c8eb318bed8407aa5e54c8b2942850d4d2.zip
new ebuild added, Molecule is the Sabayon release metatool
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/molecule')
-rw-r--r--dev-util/molecule/ChangeLog9
-rw-r--r--dev-util/molecule/metadata.xml25
-rw-r--r--dev-util/molecule/molecule-0.9.6.3.ebuild34
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-util/molecule/ChangeLog b/dev-util/molecule/ChangeLog
new file mode 100644
index 000000000000..8b52238bb6a6
--- /dev/null
+++ b/dev-util/molecule/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-util/molecule
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/ChangeLog,v 1.1 2010/06/28 14:07:54 lxnay Exp $
+
+*molecule-0.9.6.3 (28 Jun 2010)
+
+ 28 Jun 2010; Fabio Erculiani <lxnay@gentoo.org> +molecule-0.9.6.3.ebuild,
+ +metadata.xml: new ebuild added, Molecule is the Sabayon release metatool
+
diff --git a/dev-util/molecule/metadata.xml b/dev-util/molecule/metadata.xml
new file mode 100644
index 000000000000..6dd2858ca0bd
--- /dev/null
+++ b/dev-util/molecule/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>lxnay@gentoo.org</email>
+ <name>Fabio Erculiani</name>
+ </maintainer>
+ <longdescription lang="en">
+ Metro is a build tool that can build, rebuild or extend Sabayon Linux or
+ Gentoo Linux OS releases OpenVZ templates and stage4 tarballs.
+ It doesn't contain any specific package manager bit and can work with
+ your favourite one. The philosophy of Molecule is simple: ease of use and
+ modularity.
+ Just like Catalyst, Molecule uses its own .spec file format and learning
+ how to write one is just about reading examples provided inside
+ /usr/share/molecule/examples.
+ You can tweak your ISO image or create one off your chroot (stage4) in no
+ time. Molecule uses a plugin-based system to implement support for new
+ execution patterns (like ISO to ISO, ISO to Tar, Chroot to ISO, etc).
+ Molecule is born inside Sabayon and is used in its release cycle for both
+ daily(live) and versioned ISO images.
+ Molecule developers are looking for help for writing user docs and HOWTOs.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-util/molecule/molecule-0.9.6.3.ebuild b/dev-util/molecule/molecule-0.9.6.3.ebuild
new file mode 100644
index 000000000000..8a24d6146b56
--- /dev/null
+++ b/dev-util/molecule/molecule-0.9.6.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/molecule-0.9.6.3.ebuild,v 1.1 2010/06/28 14:07:54 lxnay Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit eutils multilib python base
+
+DESCRIPTION="Release metatool used for creating Sabayon (and Gentoo) releases"
+HOMEPAGE="http://www.sabayon.org"
+SRC_URI="http://distfiles.sabayon.org/dev-util/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+doc"
+
+DEPEND="${DEPEND}
+ sys-devel/gettext"
+RDEPEND="${RDEPEND}
+ app-cdr/cdrtools
+ net-misc/rsync
+ sys-fs/squashfs-tools"
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" \
+ PREFIX="/usr" SYSCONFDIR="/etc" install \
+ || die "emake install failed"
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/$(get_libdir)/molecule"
+}