summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-04-14 16:59:19 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-04-14 16:59:19 +0000
commitdae0711ff581dbaeeba92601e5be295cff972013 (patch)
tree42762d71c8fcf3f1b7605b7d036cf2cca1df6633 /games-util/dzip/dzip-2.9-r2.ebuild
parentcmake is already pulled in by cmake-utils (diff)
downloadgentoo-2-dae0711ff581dbaeeba92601e5be295cff972013.tar.gz
gentoo-2-dae0711ff581dbaeeba92601e5be295cff972013.tar.bz2
gentoo-2-dae0711ff581dbaeeba92601e5be295cff972013.zip
Use system zlib, bug #251109
(Portage version: 2.2_rc30/cvs/Linux i686)
Diffstat (limited to 'games-util/dzip/dzip-2.9-r2.ebuild')
-rw-r--r--games-util/dzip/dzip-2.9-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-util/dzip/dzip-2.9-r2.ebuild b/games-util/dzip/dzip-2.9-r2.ebuild
new file mode 100644
index 000000000000..1ed47d7aff30
--- /dev/null
+++ b/games-util/dzip/dzip-2.9-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/dzip/dzip-2.9-r2.ebuild,v 1.1 2009/04/14 16:59:19 nyhm Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="compressor/uncompressor for demo recordings from id's Quake"
+HOMEPAGE="http://speeddemosarchive.com/dzip/"
+SRC_URI="http://speeddemosarchive.com/dzip/dz${PV/./}src.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-system-zlib.patch \
+ "${FILESDIR}"/${P}-scrub-names.patch #93079
+ rm -rf zlib
+ mv -f Makefile{.linux,}
+}
+
+src_install () {
+ dogamesbin dzip || die "dogamesbin failed"
+ dodoc Readme || die "dodoc failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "Demo files can be found at http://planetquake.com/sda/"
+ elog "and http://planetquake.com/qdq/"
+ echo
+}