summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-11-09 13:40:34 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-11-09 13:40:34 +0000
commit006a2464db74648abd619dc77d4c0e44bdd59b7e (patch)
treea93d7bbeb03a245a39ac41a8e14a50969e32e227 /kde-base
parentStable on ppc wrt bug 246090 (diff)
downloadgentoo-2-006a2464db74648abd619dc77d4c0e44bdd59b7e.tar.gz
gentoo-2-006a2464db74648abd619dc77d4c0e44bdd59b7e.tar.bz2
gentoo-2-006a2464db74648abd619dc77d4c0e44bdd59b7e.zip
Fix missing cmake files by installing them with libkworkspace.
Fixes all problems with pam and misc kde packages. (Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/libkworkspace/ChangeLog9
-rw-r--r--kde-base/libkworkspace/libkworkspace-4.1.2-r1.ebuild26
-rw-r--r--kde-base/libkworkspace/libkworkspace-4.1.3.ebuild10
3 files changed, 43 insertions, 2 deletions
diff --git a/kde-base/libkworkspace/ChangeLog b/kde-base/libkworkspace/ChangeLog
index 7cc80fcd766c..39b30ec23af3 100644
--- a/kde-base/libkworkspace/ChangeLog
+++ b/kde-base/libkworkspace/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/libkworkspace
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkworkspace/ChangeLog,v 1.12 2008/11/09 02:51:33 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkworkspace/ChangeLog,v 1.13 2008/11/09 13:40:34 scarabeus Exp $
+
+*libkworkspace-4.1.2-r1 (09 Nov 2008)
+
+ 09 Nov 2008; Tomas Chvatal <scarabeus@gentoo.org>
+ +libkworkspace-4.1.2-r1.ebuild, libkworkspace-4.1.3.ebuild:
+ Modify libworkspace so it installs cmake modules for kdebase-workspace.
+ This fix most failing misc packages depending on pam.
*libkworkspace-4.1.3 (08 Nov 2008)
diff --git a/kde-base/libkworkspace/libkworkspace-4.1.2-r1.ebuild b/kde-base/libkworkspace/libkworkspace-4.1.2-r1.ebuild
new file mode 100644
index 000000000000..714824a0dd47
--- /dev/null
+++ b/kde-base/libkworkspace/libkworkspace-4.1.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkworkspace/libkworkspace-4.1.2-r1.ebuild,v 1.1 2008/11/09 13:40:34 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME=kdebase-workspace
+KMMODULE=libs/kworkspace
+KMSAVELIBS="true"
+inherit kde4-meta
+
+DESCRIPTION="A library for KDE desktop applications"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+KMEXTRA="cmake"
+KMEXTRACTONLY="ksmserver/org.kde.KSMServerInterface.xml
+ kwin/org.kde.KWin.xml"
+KMSAVELIBS="true"
+
+src_prepare() {
+ # install cmake modules here
+ sed -i \
+ -e "s/^#DONOTINSTALL //" \
+ cmake/modules/CMakeLists.txt || die "sed failed"
+}
diff --git a/kde-base/libkworkspace/libkworkspace-4.1.3.ebuild b/kde-base/libkworkspace/libkworkspace-4.1.3.ebuild
index 0019d42f266a..7b86d0d6e720 100644
--- a/kde-base/libkworkspace/libkworkspace-4.1.3.ebuild
+++ b/kde-base/libkworkspace/libkworkspace-4.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libkworkspace/libkworkspace-4.1.3.ebuild,v 1.1 2008/11/09 02:51:33 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkworkspace/libkworkspace-4.1.3.ebuild,v 1.2 2008/11/09 13:40:34 scarabeus Exp $
EAPI="2"
@@ -13,6 +13,14 @@ DESCRIPTION="A library for KDE desktop applications"
KEYWORDS="~amd64 ~x86"
IUSE="debug"
+KMEXTRA="cmake"
KMEXTRACTONLY="ksmserver/org.kde.KSMServerInterface.xml
kwin/org.kde.KWin.xml"
KMSAVELIBS="true"
+
+src_prepare() {
+ # install cmake modules here
+ sed -i \
+ -e "s/^#DONOTINSTALL //" \
+ cmake/modules/CMakeLists.txt || die "sed failed"
+}