summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-07-01 05:46:44 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-07-01 05:46:44 +0000
commit2ae50eb4c6a704797a841b90f0771065ea480631 (patch)
treed5c626d1f4ce9e94913be897b705bb3bbb861e48 /media-video
parentVersion bump. (diff)
downloadgentoo-2-2ae50eb4c6a704797a841b90f0771065ea480631.tar.gz
gentoo-2-2ae50eb4c6a704797a841b90f0771065ea480631.tar.bz2
gentoo-2-2ae50eb4c6a704797a841b90f0771065ea480631.zip
version bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.7 x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/clive/ChangeLog7
-rw-r--r--media-video/clive/clive-0.4.17.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/media-video/clive/ChangeLog b/media-video/clive/ChangeLog
index f23679a08682..8ddd881a51d1 100644
--- a/media-video/clive/ChangeLog
+++ b/media-video/clive/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/clive
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.27 2008/06/21 00:05:00 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/ChangeLog,v 1.28 2008/07/01 05:46:44 aballier Exp $
+
+*clive-0.4.17 (01 Jul 2008)
+
+ 01 Jul 2008; Alexis Ballier <aballier@gentoo.org> +clive-0.4.17.ebuild:
+ version bump
21 Jun 2008; Alexis Ballier <aballier@gentoo.org> -clive-0.4.15.ebuild:
remove old
diff --git a/media-video/clive/clive-0.4.17.ebuild b/media-video/clive/clive-0.4.17.ebuild
new file mode 100644
index 000000000000..baf6fea8761c
--- /dev/null
+++ b/media-video/clive/clive-0.4.17.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/clive/clive-0.4.17.ebuild,v 1.1 2008/07/01 05:46:44 aballier Exp $
+
+# We inherit distutils to get the pkg_* functions for byte compiling python
+inherit versionator distutils
+
+DESCRIPTION="Command line tool for extracting videos from Youtube, Google Video, Dailymotion, Guba (free) and Stage6 websites"
+HOMEPAGE="http://home.gna.org/clive/"
+SRC_URI="http://dl.gna.org/clive/$(get_version_component_range 1-2 ${PV})/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND=">=dev-lang/python-2.4
+ >=dev-libs/newt-0.51
+ >=dev-python/urlgrabber-3.1.0
+ >=dev-python/feedparser-4.1"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ # with-lib means compile its own
+ econf $(use_with doc) \
+ --without-newt \
+ --without-feedparser \
+ --without-urlgrabber
+ emake || die "emake failed"
+ if use doc; then
+ emake dox || die "failed to create the documentation"
+ fi
+}
+
+src_install() {
+ emake py_compile=true DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog README
+ use doc && dohtml dox/html/*
+}