summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-08-26 14:40:47 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-08-26 14:40:47 +0000
commit4678f37efa87e83f8b5ea99f3c11f66a0ebc4b86 (patch)
treeed3ac20d2f4aca9c6297103d62f54f039ce3456c /sci-biology/biopython/files
parentStable on alpha, bug #278545 (diff)
downloadgentoo-2-4678f37efa87e83f8b5ea99f3c11f66a0ebc4b86.tar.gz
gentoo-2-4678f37efa87e83f8b5ea99f3c11f66a0ebc4b86.tar.bz2
gentoo-2-4678f37efa87e83f8b5ea99f3c11f66a0ebc4b86.zip
clean up
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'sci-biology/biopython/files')
-rw-r--r--sci-biology/biopython/files/biopython-1.43-buildkdtree.patch28
-rw-r--r--sci-biology/biopython/files/biopython-1.44-sequtils-complement.patch32
-rw-r--r--sci-biology/biopython/files/biopython-1.47-kdtree.patch43
3 files changed, 0 insertions, 103 deletions
diff --git a/sci-biology/biopython/files/biopython-1.43-buildkdtree.patch b/sci-biology/biopython/files/biopython-1.43-buildkdtree.patch
deleted file mode 100644
index cefb16d7d95d..000000000000
--- a/sci-biology/biopython/files/biopython-1.43-buildkdtree.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- setup.py.old 2007-03-17 15:21:04.000000000 -0400
-+++ setup.py 2007-05-17 14:02:42.000000000 -0400
-@@ -64,6 +64,7 @@
- _CHECKED = check_dependencies()
- return _CHECKED
-
-+USE_KDTREE = False
- def check_dependencies():
- """Return whether the installation should continue."""
- # There should be some way for the user to tell specify not to
-@@ -112,15 +113,8 @@
-
-
- # Compile KDTree ? Not compiled by default
-- print "\n*** Bio.KDTree *** NOT built by default "
-- kdtree_msg = """
--The Bio.PDB.NeighborSearch module depends on the Bio.KDTree module,
--which in turn, depends on C++ code that does not compile cleanly on
--all platforms. Hence, Bio.KDTree is not built by default.
--
--Would you like to build Bio.KDTree ?"""
--
-- if get_yes_or_no (kdtree_msg, 0):
-+ global USE_KDTREE
-+ if USE_KDTREE:
- NUMPY_PACKAGES.append("Bio.KDTree")
- NUMPY_EXTENSIONS.append(
- CplusplusExtension('Bio.KDTree._CKDTree',
diff --git a/sci-biology/biopython/files/biopython-1.44-sequtils-complement.patch b/sci-biology/biopython/files/biopython-1.44-sequtils-complement.patch
deleted file mode 100644
index 16fc44d77cd0..000000000000
--- a/sci-biology/biopython/files/biopython-1.44-sequtils-complement.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- biopython-1.44/Bio/SeqUtils/__init__.py.old 2007-09-14 09:38:35.000000000 -0400
-+++ biopython-1.44/Bio/SeqUtils/__init__.py 2007-12-17 11:07:27.000000000 -0500
-@@ -7,8 +7,7 @@
- # license. Please see the LICENSE file that should have been included
- # as part of this package.
-
--import os, sys, getopt, re, time
--from string import maketrans
-+import re, time
- from Bio import SeqIO
- from Bio import Translate
- from Bio.Seq import Seq
-@@ -277,8 +276,9 @@
- nice looking 6 frame translation with GC content - code from xbbtools
- similar to DNA Striders six-frame translation
- """
-- comp = complement(seq)
-- anti = reverse(comp)
-+ from Bio.Seq import reverse_complement
-+ anti = reverse_complement(seq)
-+ comp = anti[::-1]
- length = len(seq)
- frames = {}
- for i in range(0,3):
-@@ -399,6 +399,7 @@
- # {{{
-
- if __name__ == '__main__':
-+ import sys, getopt
- # crude command line options to use most functions directly on a FASTA file
- options = {'apply_on_multi_fasta':0,
- 'quick':0,
diff --git a/sci-biology/biopython/files/biopython-1.47-kdtree.patch b/sci-biology/biopython/files/biopython-1.47-kdtree.patch
deleted file mode 100644
index 5d9563f2dc0c..000000000000
--- a/sci-biology/biopython/files/biopython-1.47-kdtree.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- setup.py.old 2007-03-17 15:21:04.000000000 -0400
-+++ setup.py 2007-05-17 14:02:42.000000000 -0400
-@@ -64,6 +64,7 @@
- _CHECKED = check_dependencies()
- return _CHECKED
-
-+USE_KDTREE = False
- def check_dependencies():
- """Return whether the installation should continue."""
- # There should be some way for the user to tell specify not to
-@@ -112,15 +113,8 @@
-
-
- # Compile KDTree ? Not compiled by default
-- print "\n*** Bio.KDTree *** NOT built by default "
-- kdtree_msg = """
--The Bio.PDB.NeighborSearch module depends on the Bio.KDTree module,
--which in turn, depends on C++ code that does not compile cleanly on
--all platforms. Hence, Bio.KDTree is not built by default.
--
--Would you like to build Bio.KDTree ?"""
--
-- if get_yes_or_no (kdtree_msg, 0):
-+ global USE_KDTREE
-+ if USE_KDTREE:
- NUMPY_PACKAGES.append("Bio.KDTree")
- NUMPY_EXTENSIONS.append(
- CplusplusExtension('Bio.KDTree._CKDTree',
---- Tests/test_KDTree.py.old 2008-07-05 16:32:25.000000000 -0400
-+++ Tests/test_KDTree.py 2008-07-05 16:41:33.000000000 -0400
-@@ -1,4 +1,11 @@
--from Bio.KDTree.KDTree import _neighbor_test, _test
-+from Bio import MissingExternalDependencyError
-+
-+try:
-+ from Bio.KDTree.KDTree import _neighbor_test, _test
-+except ImportError:
-+ message = 'Could not import KDTree module ' \
-+ '(not important if you do not plan to use BIO.KDTree).'
-+ raise MissingExternalDependencyError(message)
-
- nr_points=5000
- dim=3