summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-12-02 11:10:59 +0000
committerJustin Lecher <jlec@gentoo.org>2013-12-02 11:10:59 +0000
commit265f6d42799b3a6f2da60779d8400656702a53c3 (patch)
tree5cfad468cd1d3f7ef50716eae95c372f3a0ea3e4 /sci-chemistry/pymol-plugins-msms
parentsci-libs/pymmlib: Bump to distutils-r1.eclass (diff)
downloadgentoo-2-265f6d42799b3a6f2da60779d8400656702a53c3.tar.gz
gentoo-2-265f6d42799b3a6f2da60779d8400656702a53c3.tar.bz2
gentoo-2-265f6d42799b3a6f2da60779d8400656702a53c3.zip
sci-chemistry/pymol-plugins-msms: Bump to python-r1.eclass
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/pymol-plugins-msms')
-rw-r--r--sci-chemistry/pymol-plugins-msms/ChangeLog10
-rw-r--r--sci-chemistry/pymol-plugins-msms/metadata.xml10
-rw-r--r--sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415-r1.ebuild42
3 files changed, 55 insertions, 7 deletions
diff --git a/sci-chemistry/pymol-plugins-msms/ChangeLog b/sci-chemistry/pymol-plugins-msms/ChangeLog
index 1f8c1a94af08..af13415c6d6d 100644
--- a/sci-chemistry/pymol-plugins-msms/ChangeLog
+++ b/sci-chemistry/pymol-plugins-msms/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/pymol-plugins-msms
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-msms/ChangeLog,v 1.2 2011/03/22 21:09:25 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-msms/ChangeLog,v 1.3 2013/12/02 11:10:59 jlec Exp $
+
+*pymol-plugins-msms-100415-r1 (02 Dec 2013)
+
+ 02 Dec 2013; Justin Lecher <jlec@gentoo.org>
+ +pymol-plugins-msms-100415-r1.ebuild, metadata.xml:
+ Bump to python-r1.eclass
22 Mar 2011; Justin Lecher <jlec@gentoo.org>
pymol-plugins-msms-100415.ebuild:
diff --git a/sci-chemistry/pymol-plugins-msms/metadata.xml b/sci-chemistry/pymol-plugins-msms/metadata.xml
index 53db03dc2118..c6f92c968349 100644
--- a/sci-chemistry/pymol-plugins-msms/metadata.xml
+++ b/sci-chemistry/pymol-plugins-msms/metadata.xml
@@ -1,11 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-chemistry</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
-<longdescription>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
MSMS is an excellent tool for computing protein solvent excluded surface (SES).
MSMS Plugin for PyMOL provides a graphical user interface for running MSMS and
displaying its results in PyMOL.
diff --git a/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415-r1.ebuild b/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415-r1.ebuild
new file mode 100644
index 000000000000..aadcea514255
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pymol-plugins-msms/pymol-plugins-msms-100415-r1.ebuild,v 1.1 2013/12/02 11:10:59 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+DESCRIPTION="GUI for MSMS and displaying its results in PyMOL"
+HOMEPAGE="http://www.biotec.tu-dresden.de/~hongboz/msms_pymol/msms_pymol.html"
+SRC_URI="http://www.biotec.tu-dresden.de/~hongboz/msms_pymol/pymol_script/msms_pymol.py -> ${P}.py"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD pymol"
+IUSE=""
+
+RDEPEND="
+ sci-chemistry/msms-bin
+ sci-chemistry/pymol[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ mkdir "${S}" || die
+ cp "${DISTDIR}"/${A} "${S}/" || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-msms.patch
+ sed \
+ -e "s:GENTOOMSMS:${EPREFIX}/opt/bin/msms:g" \
+ -e "s:GENTOOXYZRN:${EPREFIX}/usr/bin/pdb_to_xyzrn:g" \
+ -i ${A} || die
+}
+
+src_install() {
+ python_moduleinto pmg_tk/startup
+ python_parallel_foreach_impl python_domodule ${P}.py
+ python_parallel_foreach_impl python_optimize
+}