summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-12-06 12:01:36 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-12-06 12:01:36 +0000
commit779e76a482559f405cf3acf6223543f316e5eb14 (patch)
tree804a517079dcdddb8d5fce8deed252665d1a0b4a /sci-libs/libint/libint-1.1.2.ebuild
parentCleaned up more tc stuff. (diff)
downloadgentoo-2-779e76a482559f405cf3acf6223543f316e5eb14.tar.gz
gentoo-2-779e76a482559f405cf3acf6223543f316e5eb14.tar.bz2
gentoo-2-779e76a482559f405cf3acf6223543f316e5eb14.zip
New library, used to evaluate integrals over Cartesian Gaussian functions. Useful in quantum chemistry. Is autodetected by sci-chemistry/mpqc now and used for very advanced methods, but hopefully will be able to fix that behavior soon.
(Portage version: 2.0.53)
Diffstat (limited to 'sci-libs/libint/libint-1.1.2.ebuild')
-rw-r--r--sci-libs/libint/libint-1.1.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/libint/libint-1.1.2.ebuild b/sci-libs/libint/libint-1.1.2.ebuild
new file mode 100644
index 000000000000..0a97feb6e381
--- /dev/null
+++ b/sci-libs/libint/libint-1.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/libint-1.1.2.ebuild,v 1.1 2005/12/06 12:01:36 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="Used to evaluate traditional and novel two-body matrix elements (integrals) over Cartesian Gaussian functions"
+HOMEPAGE="http://www.ccmst.gatech.edu/evaleev/libint/"
+SRC_URI="http://www.ccmst.gatech.edu/evaleev/libint/src/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/dont-append-mcpu.patch
+}
+
+src_compile() {
+ sed -i \
+ -e "s:^COPTIONS_OPT=.*:COPTIONS_OPT=\"${CFLAGS}\":g" \
+ -e "s:^CXXOPTIONS_OPT=.*:CXXOPTIONS_OPT=\"${CXXFLAGS}\":g" \
+ ${S}/configure
+
+ econf \
+ --enable-shared \
+ --enable-deriv \
+ --enable-r12 \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ #make DESTDIR=${D} install || die
+ einstall || die
+}