summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-07-26 20:06:00 +0000
committerMike Frysinger <vapier@gentoo.org>2009-07-26 20:06:00 +0000
commit592deba02c2265754685dced8f74e819922bc54d (patch)
treefb75762747c9199d88aceb85f548d0e007c1662e /sys-apps
parentadd <herd> tag (diff)
downloadgentoo-2-592deba02c2265754685dced8f74e819922bc54d.tar.gz
gentoo-2-592deba02c2265754685dced8f74e819922bc54d.tar.bz2
gentoo-2-592deba02c2265754685dced8f74e819922bc54d.zip
Add some workarounds for stable uClibc systems #249582 by Natanael Copa.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/util-linux/ChangeLog7
-rw-r--r--sys-apps/util-linux/util-linux-2.13.1.1.ebuild93
-rw-r--r--sys-apps/util-linux/util-linux-2.14.2.ebuild12
-rw-r--r--sys-apps/util-linux/util-linux-2.15-r1.ebuild101
-rw-r--r--sys-apps/util-linux/util-linux-2.15.ebuild93
5 files changed, 15 insertions, 291 deletions
diff --git a/sys-apps/util-linux/ChangeLog b/sys-apps/util-linux/ChangeLog
index c924bd61a25b..8b07df15ca8b 100644
--- a/sys-apps/util-linux/ChangeLog
+++ b/sys-apps/util-linux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/util-linux
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.273 2009/07/26 16:58:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/ChangeLog,v 1.274 2009/07/26 20:06:00 vapier Exp $
+
+ 26 Jul 2009; Mike Frysinger <vapier@gentoo.org>
+ -util-linux-2.13.1.1.ebuild, util-linux-2.14.2.ebuild,
+ -util-linux-2.15.ebuild, -util-linux-2.15-r1.ebuild:
+ Add some workarounds for stable uClibc systems #249582 by Natanael Copa.
26 Jul 2009; Mike Frysinger <vapier@gentoo.org> util-linux-2.16.ebuild,
util-linux-9999.ebuild:
diff --git a/sys-apps/util-linux/util-linux-2.13.1.1.ebuild b/sys-apps/util-linux/util-linux-2.13.1.1.ebuild
deleted file mode 100644
index d9aef43c56d1..000000000000
--- a/sys-apps/util-linux/util-linux-2.13.1.1.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.13.1.1.ebuild,v 1.9 2008/12/05 17:42:19 vapier Exp $
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
-inherit eutils
-[[ ${PV} == "9999" ]] && inherit git
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-ng-${MY_PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
-else
- SRC_URI="mirror://kernel/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2
- loop-aes? ( http://loop-aes.sourceforge.net/loop-AES/loop-AES-v3.2c.tar.bz2 )"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="crypt loop-aes nls old-linux selinux slang unicode"
-
-RDEPEND="!sys-process/schedutils
- !sys-apps/setarch
- >=sys-libs/ncurses-5.2-r2
- >=sys-fs/e2fsprogs-1.34
- selinux? ( sys-libs/libselinux )
- slang? ( sys-libs/slang )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/os-headers"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
- cd "${S}"
- ./autogen.sh || die
- else
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-2.13-uclibc.patch #203711
- use loop-aes && epatch "${WORKDIR}"/loop-AES-*/util-linux-ng-*.diff
- use unicode && sed -i 's:-lncurses:-lncursesw:' */Makefile.in #208976
- epatch "${FILESDIR}"/${PN}-2.13-ioprio-syscalls.patch #190613
- epatch "${FILESDIR}"/${PN}-2.13.1-no-a.out.patch #221939
- fi
-}
-
-src_compile() {
- econf \
- --with-fsprobe=blkid \
- $(use_enable nls) \
- --enable-agetty \
- --enable-cramfs \
- $(use_enable old-linux elvtune) \
- --disable-init \
- --disable-kill \
- --disable-last \
- --disable-mesg \
- --enable-partx \
- --enable-raw \
- --enable-rdev \
- --enable-rename \
- --disable-reset \
- --disable-login-utils \
- --enable-schedutils \
- --disable-wall \
- --enable-write \
- --without-pam \
- $(use_with selinux) \
- $(use_with slang) \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install failed"
- dodoc AUTHORS NEWS README* TODO docs/*
-
- if use crypt ; then
- newinitd "${FILESDIR}"/crypto-loop.initd crypto-loop || die
- newconfd "${FILESDIR}"/crypto-loop.confd crypto-loop || die
- fi
-}
-
-pkg_postinst() {
- ewarn "USE=crypt has been changed to USE=loop-aes. If you need"
- ewarn "support for it, make sure to update your USE accordingly."
-}
diff --git a/sys-apps/util-linux/util-linux-2.14.2.ebuild b/sys-apps/util-linux/util-linux-2.14.2.ebuild
index 5a1b9b69962c..d8d995c2cf03 100644
--- a/sys-apps/util-linux/util-linux-2.14.2.ebuild
+++ b/sys-apps/util-linux/util-linux-2.14.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+7# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.14.2.ebuild,v 1.10 2009/05/23 21:14:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.14.2.ebuild,v 1.11 2009/07/26 20:06:00 vapier Exp $
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
inherit eutils autotools
@@ -47,7 +47,13 @@ src_unpack() {
use loop-aes && epatch "${WORKDIR}"/util-linux-ng-*.diff
eautoreconf
fi
- use uclibc && sed -i -e s/versionsort/alphasort/g -e s/strverscmp.h/dirent.h/g mount/lomount.c
+ if use uclibc ; then
+ sed -i -e s/versionsort/alphasort/g -e s/strverscmp.h/dirent.h/g mount/lomount.c
+ sed -i -e 's/program_invocation_short_name/"scriptreplay"/' misc-utils/scriptreplay.c
+ sed -i -e 's/program_invocation_short_name/"setarch"/' sys-utils/setarch.c
+ sed -i -e 's/program_invocation_short_name/"ldattach"/' sys-utils/ldattach.c
+ sed -i -e 's:test = SYS_sched_getaffinity:LSDJFLSKDF = asdfasdf:' configure
+ fi
}
src_compile() {
diff --git a/sys-apps/util-linux/util-linux-2.15-r1.ebuild b/sys-apps/util-linux/util-linux-2.15-r1.ebuild
deleted file mode 100644
index 31a863e037b7..000000000000
--- a/sys-apps/util-linux/util-linux-2.15-r1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.15-r1.ebuild,v 1.3 2009/05/29 23:49:28 vapier Exp $
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
-inherit eutils autotools
-[[ ${PV} == "9999" ]] && inherit git autotools
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-ng-${MY_PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
-else
- SRC_URI="mirror://kernel/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2
- loop-aes? ( http://loop-aes.sourceforge.net/updates/util-linux-ng-2.15-20090511.diff.bz2 )"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="crypt loop-aes nls old-linux selinux slang uclibc unicode"
-
-RDEPEND="!sys-process/schedutils
- !sys-apps/setarch
- >=sys-libs/ncurses-5.2-r2
- >=sys-libs/e2fsprogs-libs-1.41
- selinux? ( sys-libs/libselinux )
- slang? ( sys-libs/slang )"
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-2
- nls? ( sys-devel/gettext )
- virtual/os-headers"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
- cd "${S}"
- eautoreconf
- else
- unpack ${A}
- cd "${S}"
- #epatch "${FILESDIR}"/${PN}-2.13-uclibc.patch #203711
- epatch "${FILESDIR}"/${P}-cpuid-pic.patch #269001
- if use loop-aes ; then
- epatch "${WORKDIR}"/util-linux-ng-*.diff
- else
- epatch "${FILESDIR}"/${P}-losetup-symlinks.patch #269264
- fi
- epatch "${FILESDIR}"/${P}-old-libselinux.patch #270168
- epatch "${FILESDIR}"/${P}-locale.patch #271154
- eautoreconf
- fi
- use uclibc && sed -i -e s/versionsort/alphasort/g -e s/strverscmp.h/dirent.h/g mount/lomount.c
-}
-
-src_compile() {
- econf \
- --with-fsprobe=blkid \
- $(use_enable nls) \
- --enable-agetty \
- --enable-cramfs \
- $(use_enable old-linux elvtune) \
- --disable-init \
- --disable-kill \
- --disable-last \
- --disable-mesg \
- --enable-partx \
- --enable-raw \
- --enable-rdev \
- --enable-rename \
- --disable-reset \
- --disable-login-utils \
- --enable-schedutils \
- --disable-wall \
- --enable-write \
- --without-pam \
- $(use unicode || echo --with-ncurses) \
- $(use_with selinux) \
- $(use_with slang) \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install failed"
- dodoc AUTHORS NEWS README* TODO docs/*
-
- if use crypt ; then
- newinitd "${FILESDIR}"/crypto-loop.initd crypto-loop || die
- newconfd "${FILESDIR}"/crypto-loop.confd crypto-loop || die
- fi
-}
-
-pkg_postinst() {
- ewarn "The loop-aes code has been split out of USE=crypt and into USE=loop-aes."
- ewarn "If you need support for it, make sure to update your USE accordingly."
-}
diff --git a/sys-apps/util-linux/util-linux-2.15.ebuild b/sys-apps/util-linux/util-linux-2.15.ebuild
deleted file mode 100644
index 64b4939cc0eb..000000000000
--- a/sys-apps/util-linux/util-linux-2.15.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.15.ebuild,v 1.3 2009/05/11 16:36:27 vapier Exp $
-
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/util-linux-ng/util-linux-ng.git"
-inherit eutils
-[[ ${PV} == "9999" ]] && inherit git
-
-MY_PV=${PV/_/-}
-MY_P=${PN}-ng-${MY_PV}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="Various useful Linux utilities"
-HOMEPAGE="http://www.kernel.org/pub/linux/utils/util-linux-ng/"
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
-else
- SRC_URI="mirror://kernel/linux/utils/util-linux-ng/v${PV:0:4}/${MY_P}.tar.bz2
- loop-aes? ( http://loop-aes.sourceforge.net/updates/util-linux-ng-2.15-20090511.diff.bz2 )"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="crypt loop-aes nls old-linux selinux slang uclibc unicode"
-
-RDEPEND="!sys-process/schedutils
- !sys-apps/setarch
- >=sys-libs/ncurses-5.2-r2
- >=sys-libs/e2fsprogs-libs-1.41
- selinux? ( sys-libs/libselinux )
- slang? ( sys-libs/slang )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/os-headers"
-
-src_unpack() {
- if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
- cd "${S}"
- ./autogen.sh || die
- else
- unpack ${A}
- cd "${S}"
- #epatch "${FILESDIR}"/${PN}-2.13-uclibc.patch #203711
- epatch "${FILESDIR}"/${P}-cpuid-pic.patch #269001
- use loop-aes && epatch "${WORKDIR}"/util-linux-ng-*.diff
- fi
- use uclibc && sed -i -e s/versionsort/alphasort/g -e s/strverscmp.h/dirent.h/g mount/lomount.c
-}
-
-src_compile() {
- econf \
- --with-fsprobe=blkid \
- $(use_enable nls) \
- --enable-agetty \
- --enable-cramfs \
- $(use_enable old-linux elvtune) \
- --disable-init \
- --disable-kill \
- --disable-last \
- --disable-mesg \
- --enable-partx \
- --enable-raw \
- --enable-rdev \
- --enable-rename \
- --disable-reset \
- --disable-login-utils \
- --enable-schedutils \
- --disable-wall \
- --enable-write \
- --without-pam \
- $(use unicode || echo --with-ncurses) \
- $(use_with selinux) \
- $(use_with slang) \
- || die "configure failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "install failed"
- dodoc AUTHORS NEWS README* TODO docs/*
-
- if use crypt ; then
- newinitd "${FILESDIR}"/crypto-loop.initd crypto-loop || die
- newconfd "${FILESDIR}"/crypto-loop.confd crypto-loop || die
- fi
-}
-
-pkg_postinst() {
- ewarn "The loop-aes code has been split out of USE=crypt and into USE=loop-aes."
- ewarn "If you need support for it, make sure to update your USE accordingly."
-}