summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-07 15:17:38 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-07 15:17:38 +0000
commita21065b639d0c67123368ab2261f824eb9d7e91e (patch)
treed524f5deca10f5f49b5e599c9546aa05cda6d909 /sys-libs
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-a21065b639d0c67123368ab2261f824eb9d7e91e.tar.gz
gentoo-2-a21065b639d0c67123368ab2261f824eb9d7e91e.tar.bz2
gentoo-2-a21065b639d0c67123368ab2261f824eb9d7e91e.zip
remove all -lgcc_eh
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r12.ebuild14
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102.ebuild4
3 files changed, 16 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.3.2-r12.ebuild b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
index c357d235b626..c5312d748e02 100644
--- a/sys-libs/glibc/glibc-2.3.2-r12.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.2 2004/11/12 16:31:32 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.3 2004/12/07 15:17:38 vapier Exp $
inherit eutils flag-o-matic gcc
@@ -16,6 +16,14 @@ export MIN_KV="2.4.1"
# you are doing !
export MIN_NPTL_KV="2.6.0"
+# (very) Theoretical cross-compiler support
+export CTARGET="${CTARGET:-${CHOST}}"
+if [[ ${CTARGET} = ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET="${CATEGORY/cross-}"
+ fi
+fi
+
MY_PV="${PV/_}"
S="${WORKDIR}/${P%_*}"
DESCRIPTION="GNU libc6 (also called glibc2) C library"
@@ -28,7 +36,9 @@ SRC_URI="http://ftp.gnu.org/gnu/glibc/glibc-${MY_PV}.tar.bz2
hppa? ( mirror://gentoo/${P}-hppa-patches-p1.tar.bz2 )"
LICENSE="LGPL-2"
-SLOT="2.2"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}-2.2" \
+ || SLOT="2.2"
KEYWORDS="alpha amd64 arm hppa ia64 mips ppc s390 sh sparc x86"
IUSE="nls pic build nptl debug"
RESTRICT="nostrip" # we'll handle stripping ourself #46186
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index 93c9ec117b5b..da4247d5604b 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.20 2004/12/07 01:44:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.21 2004/12/07 15:17:38 vapier Exp $
inherit eutils flag-o-matic gcc versionator
@@ -522,7 +522,7 @@ src_unpack() {
# http://sources.redhat.com/ml/libc-alpha/2003-09/msg00100.html
echo 'int main(){}' > ${T}/gcc_eh_test.c
if ! $(tc-getCC) ${T}/gcc_eh_test.c -lgcc_eh 2>/dev/null ; then
- sed -i -e '/static-gnulib := /s:-lgcc -lgcc_eh:-lgcc:' Makeconfig
+ sed -i -e 's:-lgcc_eh::' Makeconfig || die "sed gcc_eh"
fi
# hardened toolchain/relro/nptl/security/etc fixes
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
index cf404608eebc..25760007ab07 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.13 2004/12/07 01:44:14 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.14 2004/12/07 15:17:38 vapier Exp $
inherit eutils flag-o-matic gcc versionator
@@ -546,7 +546,7 @@ src_unpack() {
# http://sources.redhat.com/ml/libc-alpha/2003-09/msg00100.html
echo 'int main(){}' > ${T}/gcc_eh_test.c
if ! $(tc-getCC) ${T}/gcc_eh_test.c -lgcc_eh 2>/dev/null ; then
- sed -i -e '/static-gnulib := /s:-lgcc -lgcc_eh:-lgcc:' Makeconfig
+ sed -i -e 's:-lgcc_eh::' Makeconfig || die "sed gcc_eh"
fi
# hardened toolchain/relro/nptl/security/etc fixes