summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-12-21 22:10:19 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-12-21 22:10:19 +0000
commitae637c5a694a47796a159017ea82a6a16f5a8f8a (patch)
treec9d039800e13307b7f7b56df61fbd7de2d18dc1f /x11-libs/gtksourceview
parentnow really fix vdpau (diff)
downloadgentoo-2-ae637c5a694a47796a159017ea82a6a16f5a8f8a.tar.gz
gentoo-2-ae637c5a694a47796a159017ea82a6a16f5a8f8a.tar.bz2
gentoo-2-ae637c5a694a47796a159017ea82a6a16f5a8f8a.zip
Version bump. Bug fixes and translation updates. Drop buggy .la files removal lines.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/ChangeLog9
-rw-r--r--x11-libs/gtksourceview/gtksourceview-2.8.2.ebuild42
2 files changed, 50 insertions, 1 deletions
diff --git a/x11-libs/gtksourceview/ChangeLog b/x11-libs/gtksourceview/ChangeLog
index 0a4f9aa4c71f..28b9cd383619 100644
--- a/x11-libs/gtksourceview/ChangeLog
+++ b/x11-libs/gtksourceview/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/gtksourceview
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.169 2009/12/03 17:01:04 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.170 2009/12/21 22:10:19 eva Exp $
+
+*gtksourceview-2.8.2 (21 Dec 2009)
+
+ 21 Dec 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +gtksourceview-2.8.2.ebuild:
+ Version bump. Bug fixes and translation updates. Drop buggy .la files
+ removal lines.
03 Dec 2009; Brent Baude <ranger@gentoo.org> gtksourceview-2.6.2.ebuild:
Marking gtksourceview-2.6.2 ppc64 stable for bug 281427
diff --git a/x11-libs/gtksourceview/gtksourceview-2.8.2.ebuild b/x11-libs/gtksourceview/gtksourceview-2.8.2.ebuild
new file mode 100644
index 000000000000..bf3493b8acc7
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-2.8.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-2.8.2.ebuild,v 1.1 2009/12/21 22:10:19 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/glib-2.14"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-2.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang || die "doins failed"
+}