summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/netwmpager/netwmpager-1.6.ebuild')
-rw-r--r--x11-misc/netwmpager/netwmpager-1.6.ebuild34
1 files changed, 16 insertions, 18 deletions
diff --git a/x11-misc/netwmpager/netwmpager-1.6.ebuild b/x11-misc/netwmpager/netwmpager-1.6.ebuild
index 180c23ddc37a..c1d938452a2f 100644
--- a/x11-misc/netwmpager/netwmpager-1.6.ebuild
+++ b/x11-misc/netwmpager/netwmpager-1.6.ebuild
@@ -1,38 +1,36 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/netwmpager/netwmpager-1.6.ebuild,v 1.4 2006/02/11 11:18:28 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/netwmpager/netwmpager-1.6.ebuild,v 1.5 2006/10/28 22:30:39 omp Exp $
DESCRIPTION="EWMH (NetWM) compatible pager. Works with Openbox and other EWMH
compliant window managers."
-SRC_URI="http://onion.dynserv.net/~timo/files/${P}.tar.bz2"
HOMEPAGE="http://onion.dynserv.net/~timo/?page=Projects/netwmpager"
+SRC_URI="http://onion.dynserv.net/~timo/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~ppc x86"
IUSE=""
-RDEPEND="|| ( (
- x11-libs/libX11
- x11-libs/libXrender
- x11-libs/libXft
- x11-libs/libXdmcp
- x11-libs/libXau )
- virtual/x11 )"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXft
+ x11-libs/libXdmcp
+ x11-libs/libXau"
DEPEND="${RDEPEND}
- || ( x11-proto/xproto virtual/x11 )
- virtual/xft"
-
-LICENSE="GPL-2"
-KEYWORDS="~ppc x86"
+ dev-util/pkgconfig
+ virtual/xft
+ x11-proto/xproto"
src_compile()
{
# econf doesn't work
- ./configure --prefix=/usr || die
- emake || die
+ ./configure --prefix=/usr || die "configure failed"
+ emake || die "emake failed"
}
src_install ()
{
- make DESTDIR=${D} install || die
-
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog README THANKS TODO
}