summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/netwmpager/ChangeLog5
-rw-r--r--x11-misc/netwmpager/files/digest-netwmpager-1.62
-rw-r--r--x11-misc/netwmpager/netwmpager-1.6.ebuild34
3 files changed, 22 insertions, 19 deletions
diff --git a/x11-misc/netwmpager/ChangeLog b/x11-misc/netwmpager/ChangeLog
index 1fc57f6b3865..81d551b599d1 100644
--- a/x11-misc/netwmpager/ChangeLog
+++ b/x11-misc/netwmpager/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-misc/netwmpager
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/netwmpager/ChangeLog,v 1.4 2006/02/11 11:18:28 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/netwmpager/ChangeLog,v 1.5 2006/10/28 22:30:39 omp Exp $
+
+ 28 Oct 2006; David Shakaryan <omp@gentoo.org> netwmpager-1.6.ebuild:
+ Remove monolithic X support and add pkgconfig to DEPEND. (bug #150804)
11 Feb 2006; Krzysiek Pawlik <nelchael@gentoo.org> netwmpager-1.6.ebuild:
Fixed DEPEND for modular X.
diff --git a/x11-misc/netwmpager/files/digest-netwmpager-1.6 b/x11-misc/netwmpager/files/digest-netwmpager-1.6
index 9d0e5a6a75f0..87c444c38ae1 100644
--- a/x11-misc/netwmpager/files/digest-netwmpager-1.6
+++ b/x11-misc/netwmpager/files/digest-netwmpager-1.6
@@ -1 +1,3 @@
MD5 d9225f9628d120685abe41cb51395d02 netwmpager-1.6.tar.bz2 44407
+RMD160 819ce9a79e4cd34780e48139b0daa0abd459ca95 netwmpager-1.6.tar.bz2 44407
+SHA256 972fbc3ef09ef34272e48da5da8cc5e71f92f175258e74d24aff13888057a3e5 netwmpager-1.6.tar.bz2 44407
diff --git a/x11-misc/netwmpager/netwmpager-1.6.ebuild b/x11-misc/netwmpager/netwmpager-1.6.ebuild
index 180c23ddc37a..c1d938452a2f 100644
--- a/x11-misc/netwmpager/netwmpager-1.6.ebuild
+++ b/x11-misc/netwmpager/netwmpager-1.6.ebuild
@@ -1,38 +1,36 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/netwmpager/netwmpager-1.6.ebuild,v 1.4 2006/02/11 11:18:28 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/netwmpager/netwmpager-1.6.ebuild,v 1.5 2006/10/28 22:30:39 omp Exp $
DESCRIPTION="EWMH (NetWM) compatible pager. Works with Openbox and other EWMH
compliant window managers."
-SRC_URI="http://onion.dynserv.net/~timo/files/${P}.tar.bz2"
HOMEPAGE="http://onion.dynserv.net/~timo/?page=Projects/netwmpager"
+SRC_URI="http://onion.dynserv.net/~timo/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~ppc x86"
IUSE=""
-RDEPEND="|| ( (
- x11-libs/libX11
- x11-libs/libXrender
- x11-libs/libXft
- x11-libs/libXdmcp
- x11-libs/libXau )
- virtual/x11 )"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXft
+ x11-libs/libXdmcp
+ x11-libs/libXau"
DEPEND="${RDEPEND}
- || ( x11-proto/xproto virtual/x11 )
- virtual/xft"
-
-LICENSE="GPL-2"
-KEYWORDS="~ppc x86"
+ dev-util/pkgconfig
+ virtual/xft
+ x11-proto/xproto"
src_compile()
{
# econf doesn't work
- ./configure --prefix=/usr || die
- emake || die
+ ./configure --prefix=/usr || die "configure failed"
+ emake || die "emake failed"
}
src_install ()
{
- make DESTDIR=${D} install || die
-
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog README THANKS TODO
}