summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2015-11-19 00:00:11 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2015-11-19 00:00:11 +0000
commit47b56a9dacdf67e0f46d75d2279d573aa65a792f (patch)
treea3e6240b086b68daedc2fee283cb7fd3ce231ba7
parentsci-libs/netcdf-fortran: version bump (diff)
downloadbicatali-47b56a9dacdf67e0f46d75d2279d573aa65a792f.tar.gz
bicatali-47b56a9dacdf67e0f46d75d2279d573aa65a792f.tar.bz2
bicatali-47b56a9dacdf67e0f46d75d2279d573aa65a792f.zip
sci-libs/netcdf: version bump
Package-Manager: portage-2.2.25
-rw-r--r--sci-libs/netcdf/Manifest1
-rw-r--r--sci-libs/netcdf/metadata.xml18
-rw-r--r--sci-libs/netcdf/netcdf-4.3.3.1.ebuild56
3 files changed, 75 insertions, 0 deletions
diff --git a/sci-libs/netcdf/Manifest b/sci-libs/netcdf/Manifest
new file mode 100644
index 0000000..b947104
--- /dev/null
+++ b/sci-libs/netcdf/Manifest
@@ -0,0 +1 @@
+DIST netcdf-4.3.3.1.tar.gz 4999463 SHA256 bdde3d8b0e48eed2948ead65f82c5cfb7590313bc32c4cf6c6546e4cea47ba19 SHA512 a14e126ec3dcb4c7c68e82b20cd149f391ff9f2f733f19a93b159c1529e04ee2a66128962a4534cfe1f37e1c8a100f92def4f79069f5359c95a819715f62acef WHIRLPOOL 17d5ea91954fa85d110675066c04695739b4a36bd42eeeb14c678d7927dc1f22aadd075d10f754b3e4655c1cebd242fc80b6999c50b3660ec7334f4180bce3ee
diff --git a/sci-libs/netcdf/metadata.xml b/sci-libs/netcdf/metadata.xml
new file mode 100644
index 0000000..d78394e
--- /dev/null
+++ b/sci-libs/netcdf/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ NetCDF (network Common Data Form) is an interface for scientific
+ data access and a freely-distributed software library that provides an
+ implementation of the interface. The netCDF library also defines a
+ machine-independent format for representing scientific data.
+ Together, the interface, library, and format support the creation,
+ access, and sharing of scientific data.
+</longdescription>
+ <use>
+ <flag name="dap">Support for remote data access with the built-in OPeNDAP client</flag>
+ <flag name="hdf">Add support for the Hierarchical Data Format v.4 <pkg>sci-libs/hdf</pkg></flag>
+ <flag name="tools">Build the utilities nccopy, ncgen and ncdump</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-libs/netcdf/netcdf-4.3.3.1.ebuild b/sci-libs/netcdf/netcdf-4.3.3.1.ebuild
new file mode 100644
index 0000000..347d2b3
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-4.3.3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
+
+LICENSE="UCAR-Unidata"
+SLOT="0/7"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+dap doc examples hdf +hdf5 mpi static-libs szip test tools"
+
+RDEPEND="
+ dap? ( net-misc/curl:0= )
+ hdf? ( sci-libs/hdf:0= sci-libs/hdf5:0= )
+ hdf5? ( sci-libs/hdf5:0=[mpi=,szip=,zlib] )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+REQUIRED_USE="test? ( tools ) szip? ( hdf5 ) mpi? ( hdf5 )"
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-examples
+ --disable-dap-remote-tests
+ $(use_enable dap)
+ $(use_enable doc doxygen)
+ $(use_enable hdf hdf4)
+ $(use_enable hdf5 netcdf-4)
+ $(use_enable tools utilities)
+ )
+ if use mpi; then
+ export CC=mpicc
+ myeconfargs+=( --enable-parallel )
+ use test && myeconfargs+=( --enable-parallel-tests )
+ fi
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test -j1
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}