summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2007-06-10 14:58:47 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2007-06-10 14:58:47 +0000
commitafdc47cf1cca0422886d0eee96cbbf674a9c6915 (patch)
tree9eba94478fc0481db64187001aee71bffe893274
parentversion bump (diff)
downloaddertobi123-afdc47cf1cca0422886d0eee96cbbf674a9c6915.tar.gz
dertobi123-afdc47cf1cca0422886d0eee96cbbf674a9c6915.tar.bz2
dertobi123-afdc47cf1cca0422886d0eee96cbbf674a9c6915.zip
Initial import
svn path=/; revision=7
-rw-r--r--net-analyzer/ndoutils/Manifest8
-rw-r--r--net-analyzer/ndoutils/files/digest-ndoutils-1.4_beta33
-rw-r--r--net-analyzer/ndoutils/ndoutils-1.4_beta3.ebuild55
3 files changed, 66 insertions, 0 deletions
diff --git a/net-analyzer/ndoutils/Manifest b/net-analyzer/ndoutils/Manifest
new file mode 100644
index 0000000..2cdac7f
--- /dev/null
+++ b/net-analyzer/ndoutils/Manifest
@@ -0,0 +1,8 @@
+DIST ndoutils-1.4b3.tar.gz 929275 RMD160 b819c3e6d10c795e9089aed299874aa978d9ff82 SHA1 3013d198250517d89a6623e011edc130f68943fd SHA256 d0de665c3ca377e721309a18c746cbc69a31b2c2ec8fd04376a56d2eb9c021ae
+EBUILD ndoutils-1.4_beta3.ebuild 1459 RMD160 c2c9d2300f9e4dfdbaf718c5698ff86f1ae65dec SHA1 ea05b20ae72dcc9657daee6d7e4b0af20ad8869a SHA256 db36bcba1f176859b995b395b9f063be2d2eac16350834d04198f539c8f78928
+MD5 ef49560d14ee02f2d5cad18033141802 ndoutils-1.4_beta3.ebuild 1459
+RMD160 c2c9d2300f9e4dfdbaf718c5698ff86f1ae65dec ndoutils-1.4_beta3.ebuild 1459
+SHA256 db36bcba1f176859b995b395b9f063be2d2eac16350834d04198f539c8f78928 ndoutils-1.4_beta3.ebuild 1459
+MD5 55abe92d669027b51d91b28b704d81fa files/digest-ndoutils-1.4_beta3 244
+RMD160 065d6584eb73e0ecd58b1e52cf74d7b8d47d29dd files/digest-ndoutils-1.4_beta3 244
+SHA256 5312b45eb8894ccfcaa878b0ed306951faa23194590173a669e3e75d99e2b472 files/digest-ndoutils-1.4_beta3 244
diff --git a/net-analyzer/ndoutils/files/digest-ndoutils-1.4_beta3 b/net-analyzer/ndoutils/files/digest-ndoutils-1.4_beta3
new file mode 100644
index 0000000..58b1eab
--- /dev/null
+++ b/net-analyzer/ndoutils/files/digest-ndoutils-1.4_beta3
@@ -0,0 +1,3 @@
+MD5 9da74b66a0af637d107257627e13beba ndoutils-1.4b3.tar.gz 929275
+RMD160 b819c3e6d10c795e9089aed299874aa978d9ff82 ndoutils-1.4b3.tar.gz 929275
+SHA256 d0de665c3ca377e721309a18c746cbc69a31b2c2ec8fd04376a56d2eb9c021ae ndoutils-1.4b3.tar.gz 929275
diff --git a/net-analyzer/ndoutils/ndoutils-1.4_beta3.ebuild b/net-analyzer/ndoutils/ndoutils-1.4_beta3.ebuild
new file mode 100644
index 0000000..e6e8083
--- /dev/null
+++ b/net-analyzer/ndoutils/ndoutils-1.4_beta3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.5.5.ebuild,v 1.1 2007/06/07 06:43:34 dertobi123 Exp $
+
+MY_P=${P/_beta/b}
+
+DESCRIPTION="Nagios addon to store Nagios data in a MySQL database"
+HOMEPAGE="http://www.nagios.org"
+SRC_URI="mirror://sourceforge/nagios/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-db/mysql"
+RDEPEND="${DEPEND}
+ >=net-analyzer/nagios-core-2.7"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+src_compile() {
+ econf \
+ --prefix=/usr/nagios \
+ --sysconfdir=/etc/nagios \
+ --enable-mysql \
+ --disable-pgsql || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/nagios/bin
+ cp ${S}/src/{file2sock,log2ndo,ndo2db-2x,ndomod-2x.o,sockdebug} ${D}/usr/nagios/bin
+
+ dodir /usr/nagios/share/
+ cp -R ${S}/db ${D}/usr/nagios/share
+
+ chown -R nagios:nagios ${D}/usr/nagios || die "Failed chown of ${D}/usr/nagios"
+ chmod 750 ${D}/usr/nagios/bin/{file2sock,log2ndo,ndo2db-2x,ndomod-2x.o,sockdebug} || "Failed chmod"
+
+ dodoc README REQUIREMENTS TODO UPGRADING Changelog "docs/NDOUTILS DB Model.pdf" "docs/NDOUtils Documentation.pdf"
+
+cat << EOF > "${T}"/55-ndoutils-revdep
+SEARCH_DIRS="/usr/nagios/bin"
+EOF
+
+ insinto /etc/revdep-rebuild
+ doins "${T}"/55-ndoutils-revdep
+}