summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-fps/ut2004')
-rw-r--r--games-fps/ut2004/Manifest4
-rw-r--r--games-fps/ut2004/files/ut2004.xml7
-rw-r--r--games-fps/ut2004/ut2004-3369-r4.ebuild161
-rw-r--r--games-fps/ut2004/ut2004-3369-r5.ebuild168
4 files changed, 0 insertions, 340 deletions
diff --git a/games-fps/ut2004/Manifest b/games-fps/ut2004/Manifest
deleted file mode 100644
index b567aab..0000000
--- a/games-fps/ut2004/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX ut2004.xml 370 RMD160 f54254f4af9422b72e93b9f4e2aa126b828c34f4 SHA1 53be0a7e6cd5ea1c5329fee791e527b9f8edf29a SHA256 69d2ad349f8b0464157979518ca3482b6b8bbc34f25d710668775f36581be34c
-DIST ut2004-lnxpatch3369-2.tar.bz2 22465217 RMD160 af632d8cd1f05e36e861eb3fab927ffc8ae3f59d SHA1 a8cc33877a02a0a09c288b5fc248efde282f7bdf SHA256 438b9b13a367d46f23cce12b065382a55afa2fc68add1f1dd3db03b015f60bb3
-EBUILD ut2004-3369-r4.ebuild 5231 RMD160 177c8a492778d27a068b319dad0b8416c40a37a5 SHA1 c7c8c8b67088b58bdf68322a45bef3eda196a200 SHA256 c68ba993ce55178f2cf1935d1c23c3a1a412781ed958c59842453c26eba61e23
-EBUILD ut2004-3369-r5.ebuild 4915 RMD160 b5e5f16dbd2cf6fb603a355d60d37367d3d1aaef SHA1 e35d482fc4adb65149e654505a48135d442d677b SHA256 335db326c4ffa65da261d0c24eeb7d319b009b8c945fd110f23f65aafc38d17d
diff --git a/games-fps/ut2004/files/ut2004.xml b/games-fps/ut2004/files/ut2004.xml
deleted file mode 100644
index f87f48c..0000000
--- a/games-fps/ut2004/files/ut2004.xml
+++ /dev/null
@@ -1,7 +0,0 @@
-<?xml version="1.0"?>
-<product name="ut2004" desc="Unreal Tournament 2004" xmlversion="1.6" root="GAMES_PREFIX_OPT/ut2004" update_url="http://unreal.epicgames.com/updates/ut2004/updates.txt">
- <component name="__CDKEY__" version="3369" default="yes">
- <option name="English"></option>
- <option name="__CDKEY__" tag="__CDKEY__"></option>
- </component>
-</product>
diff --git a/games-fps/ut2004/ut2004-3369-r4.ebuild b/games-fps/ut2004/ut2004-3369-r4.ebuild
deleted file mode 100644
index 8d99dc2..0000000
--- a/games-fps/ut2004/ut2004-3369-r4.ebuild
+++ /dev/null
@@ -1,161 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004/ut2004-3369-r4.ebuild,v 1.16 2007/02/17 08:54:50 nyhm Exp $
-
-# To use system libraries, uncomment the following line and comment the one
-# below it.
-#inherit eutils multilib games
-inherit eutils games
-
-MY_P="${PN}-lnxpatch${PV}-2.tar.bz2"
-DESCRIPTION="Editor's Choice Edition plus Mega Pack for the critically-acclaimed first-person shooter"
-HOMEPAGE="http://www.unrealtournament2004.com/"
-SRC_URI="mirror://3dgamers/unrealtourn2k4/${MY_P}
- http://speculum.twistedgamer.com/pub/0day.icculus.org/${PN}/${MY_P}
- http://treefort.icculus.org/${PN}/${MY_P}
- http://sonic-lux.net/data/mirror/ut2004/${MY_P}"
-
-LICENSE="ut2003"
-SLOT="0"
-KEYWORDS="amd64 x86"
-# The executable pages are required.
-QA_EXECSTACK_x86="${GAMES_PREFIX_OPT:1}/ut2004/System/ut2004-bin
- ${GAMES_PREFIX_OPT:1}/ut2004/System/ucc-bin"
-QA_EXECSTACK_amd64="${GAMES_PREFIX_OPT:1}/ut2004/System/ut2004-bin
- ${GAMES_PREFIX_OPT:1}/ut2004/System/ucc-bin"
-RESTRICT="mirror strip"
-IUSE="dedicated opengl"
-
-RDEPEND=">=games-fps/ut2004-data-3186-r2
- >=games-fps/ut2004-bonuspack-ece-1-r1
- >=games-fps/ut2004-bonuspack-mega-1-r1
- opengl? (
- virtual/opengl )
- =virtual/libstdc++-3.3
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp"
- # If you wish to use your system libSDL/openal, then you will need to remove
- # the comments from the following two lines, along with the quotes above and
- # this comment text.
-# >=media-libs/libsdl-1.2
-# media-libs/openal"
-
-S=${WORKDIR}/UT2004-Patch
-
-GAMES_CHECK_LICENSE="yes"
-dir=${GAMES_PREFIX_OPT}/${PN}
-Ddir=${D}/${dir}
-
-src_install() {
- # These files are owned by ut2004-bonuspack-mega
- rm "${S}"/System/{Manifest.in{i,t},Packages.md5}
-
- # Installing patch files
- for p in {Animations,Help,Speech,System,Textures,Web}
- do
- dodir "${dir}/${p}"
- cp -r "${S}/${p}"/* "${Ddir}/${p}" \
- || die "copying ${p} from patch"
- done
-
- # To use system libraries, rather than binaries from ut2004-data, you will
- # need to uncomment these three lines, as well as ensure that you have both
- # libsdl and openal installed.
-# dosym /usr/$(get_libdir)/libopenal.so "${dir}"/System/openal.so || die
-# dosym /usr/$(get_libdir)/libSDL-1.2.so.0 "${dir}"/System/libSDL-1.2.so.0 \
-# || die
-
- use amd64 && rm "${Ddir}"/System/u{cc,t2004}-bin \
- && mv "${Ddir}"/System/ucc-bin-linux-amd64 "${Ddir}"/System/ucc-bin \
- && mv "${Ddir}"/System/ut2004-bin-linux-amd64 \
- "${Ddir}"/System/ut2004-bin \
- && chmod ug+x "${Ddir}"/System/ucc-bin "${Ddir}"/System/ut2004-bin
- use x86 && rm "${Ddir}"/System/ucc-bin-linux-amd64 \
- "${Ddir}"/System/ut2004-bin-linux-amd64
-
- # Creating .manifest files
- sed -e "s:GAMES_PREFIX_OPT:${GAMES_PREFIX_OPT}:" "${FILESDIR}"/${PN}.xml > \
- ${T}/${PN}.xml || die "sed failed"
- insinto "${dir}"/.manifest
- doins "${T}"/${PN}.xml
-
- # Creating .loki/installed links
- mkdir -p "${D}"/root/.loki/installed
- dosym "${dir}"/.manifest/${PN}.xml /root/.loki/installed/${PN}.xml
-
- games_make_wrapper ut2004 ./ut2004 "${dir}" "${dir}"
-
- prepgamesdirs
- make_desktop_entry ut2004 "Unreal Tournament 2004" ut2004.xpm
-}
-
-pkg_postinst() {
- games_pkg_postinst
-
- # Here is where we check for the existence of a cdkey...
- # If we don't find one, we ask the user for it
- if [[ -f "${dir}/System/cdkey" ]]
- then
- einfo "A cdkey file is already present in ${dir}/System"
- else
- ewarn "You MUST run this before playing the game:"
- ewarn "emerge --config =${CATEGORY}/${PF}"
- ewarn "That way you can [re]enter your cdkey."
- fi
- echo
- elog "Starting with 3369, the game supports render-to-texture. To enable"
- elog "it, you will need the Nvidia drivers of at least version 7676 and"
- elog "you should edit the following:"
- elog 'Set "UseRenderTargets=True" in the "[OpenGLDrv.OpenGLRenderDevice]"'
- elog 'section of your UT2004.ini/Default.ini and set "bPlayerShadows=True"'
- elog 'and "bBlobShadow=False" in the "[UnrealGame.UnrealPawn]" section of'
- elog 'your User.ini/DefUser.ini'
- echo
- if use x86
- then
- elog "The 32-bit version of UT2004 uses Pixomatic, which means it"
- elog "really does need an executable stack. It is safe to ignore any"
- elog "warnings from portage about this. See:"
- elog "http://bugs.gentoo.org/show_bug.cgi?id=114733"
- elog "for more information."
- echo
- fi
- elog "To play the game run:"
- elog " ut2004"
- echo
-}
-
-pkg_postrm() {
- ewarn "This package leaves a cdkey file in ${dir}/System that you need"
- ewarn "to remove to completely get rid of this game's files."
-}
-
-pkg_config() {
- ewarn "Your CD key is NOT checked for validity here."
- ewarn " Make sure you type it in correctly."
- eerror "If you CTRL+C out of this, the game will not run!"
- echo
- einfo "CD key format is: XXXXX-XXXXX-XXXXX-XXXXX"
- while true
- do
- einfo "Please enter your CD key:"
- read CDKEY1
- einfo "Please re-enter your CD key:"
- read CDKEY2
- if [[ "$CDKEY1" == "" ]]
- then
- echo "You entered a blank CD key. Try again."
- else
- if [[ "$CDKEY1" == "$CDKEY2" ]]
- then
- echo "$CDKEY1" | tr a-z A-Z > "${dir}"/System/cdkey
- einfo "Thank you!"
- break
- else
- eerror "Your CD key entries do not match. Try again."
- fi
- fi
- done
-}
diff --git a/games-fps/ut2004/ut2004-3369-r5.ebuild b/games-fps/ut2004/ut2004-3369-r5.ebuild
deleted file mode 100644
index f3515b5..0000000
--- a/games-fps/ut2004/ut2004-3369-r5.ebuild
+++ /dev/null
@@ -1,168 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils games
-
-MY_P="${PN}-lnxpatch${PV}-2.tar.bz2"
-
-DESCRIPTION="Editor's Choice Edition plus Mega Pack for the critically-acclaimed first-person shooter"
-HOMEPAGE="http://www.unrealtournament2004.com/"
-SRC_URI="mirror://3dgamers/unrealtourn2k4/${MY_P}
- http://speculum.twistedgamer.com/pub/0day.icculus.org/${PN}/${MY_P}
- http://treefort.icculus.org/${PN}/${MY_P}
- http://sonic-lux.net/data/mirror/ut2004/${MY_P}"
-
-LICENSE="ut2003"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="dedicated opengl"
-RESTRICT="mirror strip"
-
-RDEPEND=">=games-fps/ut2004-data-3186-r2
- >=games-fps/ut2004-bonuspack-ece-1-r1
- >=games-fps/ut2004-bonuspack-mega-1-r1
- opengl? ( virtual/opengl )
- =virtual/libstdc++-3.3
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp"
-
-S=${WORKDIR}/UT2004-Patch
-dir=${GAMES_PREFIX_OPT}/${PN}
-
-QA_EXECSTACK="${dir:1}/System/ut2004-bin
- ${dir:1}/System/ucc-bin"
-
-GAMES_CHECK_LICENSE="yes"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Newbie check
- if [[ ! -e "${FILESDIR}/${PN}.xml" ]] ; then
- die "Missing: ${FILESDIR}/${PN}.xml"
- fi
-
- if use x86 ; then
- rm -f System/{ucc,ut2004}-bin-linux-amd64
- else
- mv -f System/ucc-bin-linux-amd64 System/ucc-bin || die
- mv -f System/ut2004-bin-linux-amd64 System/ut2004-bin || die
- fi
-}
-
-src_install() {
- # These files are owned by ut2004-bonuspack-mega
- rm -f System/{Manifest.in{i,t},Packages.md5}
-
- # Installing patch files
- local d
- for d in Animations Help Speech System Textures Web ; do
- insinto "${dir}"
- doins -r "${d}" || die "doins ${p} from patch"
- done
-
- rm -f "${D}/${dir}/System"/{ucc,ut2004}-bin
- exeinto "${dir}/System"
- doexe System/{ucc,ut2004}-bin || die "doexe failed"
-
- # Creating .manifest files
- sed -e "s:GAMES_PREFIX_OPT:${GAMES_PREFIX_OPT}:" "${FILESDIR}"/${PN}.xml > \
- "${T}"/${PN}.xml || die "sed ${PN}.xml failed"
- insinto "${dir}"/.manifest
- doins "${T}"/${PN}.xml
-
- # Creating .loki/installed links
- mkdir -p "${D}"/root/.loki/installed
- dosym "${dir}"/.manifest/${PN}.xml /root/.loki/installed/${PN}.xml
-
- # Replaces the /opt/ut2004/ut2004 script, which is not provided on
- # the Anthology DVD.
- # games-mods.eclass requires the /opt/ut2004/ut2004 script, for mods.
- games_make_wrapper ut2004 ./ut2004 "${dir}"
-
- echo -e "#!/bin/sh\ncd System\nif [[ \"\${LD_LIBRARY_PATH+set}\" = \"set\" ]] ; then\n\texport LD_LIBRARY_PATH=\"..:.\"\nelse\n\texport LD_LIBRARY_PATH=\"\${LD_LIBRARY_PATH}:..:.\"\nfi\nexec ./ut2004-bin \"\$@\"" \
- > ut2004 || die
- exeinto "${dir}"
- doexe ut2004 || die
-
- make_desktop_entry ut2004 "Unreal Tournament 2004" ut2004.xpm
-
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
-
- # Here is where we check for the existence of a CD key...
- # If we don't find one, we ask the user for it.
- if [[ -f "${dir}/System/cdkey" ]] ; then
- einfo "A CD key file is already present in ${dir}/System"
- else
- ewarn "You MUST run this before playing the game:"
- ewarn "emerge --config =${CATEGORY}/${PF}"
- ewarn "That way you can [re]enter your CD key."
- fi
- echo
- elog "Starting with 3369, the game supports render-to-texture. To enable"
- elog "it, you will need the Nvidia drivers of at least version 7676 and"
- elog "you should edit the following:"
- elog
- elog 'Set "UseRenderTargets=True" in the "[OpenGLDrv.OpenGLRenderDevice]"'
- elog 'section of your UT2004.ini/Default.ini and set "bPlayerShadows=True"'
- elog 'and "bBlobShadow=False" in the "[UnrealGame.UnrealPawn]" section of'
- elog 'your User.ini/DefUser.ini'
- if use x86 ; then
- elog
- elog "The 32-bit version of UT2004 uses Pixomatic, which means it"
- elog "really does need an executable stack. It is safe to ignore any"
- elog "warnings from Portage about this. See:"
- elog "http://bugs.gentoo.org/show_bug.cgi?id=114733"
- elog "for more information."
- fi
- elog
- elog "To play the game, run:"
- elog " ut2004"
- echo
-}
-
-pkg_postrm() {
- ewarn "This package leaves a CD key file that you"
- ewarn "need to remove, to completely get rid of this game's files:"
- ewarn "${dir}/System/cdkey"
-}
-
-pkg_config() {
- local cdkey1 cdkey2
-
- ewarn "Your CD key is NOT checked for validity here."
- ewarn "Make sure you type it in correctly."
- eerror "If you CTRL+C out of this, the game will not run!"
- echo
- einfo "CD key format is: XXXXX-XXXXX-XXXXX-XXXXX"
- while true ; do
- einfo "Please enter your CD key:"
- read cdkey1
- if [[ "${cdkey1}" == "" ]] ; then
- echo "You entered a blank CD key. Try again."
- continue
- fi
- einfo "Please re-enter your CD key:"
- read cdkey2
- if [[ "${cdkey2}" == "" ]] ; then
- echo "You entered a blank CD key. Try again."
- continue
- fi
-
- if [[ "${cdkey1}" == "${cdkey2}" ]] ; then
- echo "${cdkey1}" | tr a-z A-Z > "${dir}"/System/cdkey
- einfo "Thanks, created ${dir}/System/cdkey"
- break
- else
- eerror "Your CD key entries do not match. Try again."
- fi
- done
-}