aboutsummaryrefslogtreecommitdiff
path: root/etc
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2014-01-19 23:39:41 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2014-01-19 23:39:41 +0100
commit2fa30f99c9476940431563b8f2efced907d7e092 (patch)
treed8e5aca296c24224a0752687ff2134d4ce8791f8 /etc
parentadded systemd service file, systemd helper script; wrt bug 353492 (diff)
downloadgentoo-vdr-scripts-2fa30f99c9476940431563b8f2efced907d7e092.tar.gz
gentoo-vdr-scripts-2fa30f99c9476940431563b8f2efced907d7e092.tar.bz2
gentoo-vdr-scripts-2fa30f99c9476940431563b8f2efced907d7e092.zip
added Makefiles for systemd relevanted files; systemd handling in main Makefile added
Diffstat (limited to 'etc')
-rw-r--r--etc/systemd/system/vdr.service.d/00-gentoo-vdr-user.conf8
-rw-r--r--etc/systemd/system/vdr.service.d/Makefile16
2 files changed, 24 insertions, 0 deletions
diff --git a/etc/systemd/system/vdr.service.d/00-gentoo-vdr-user.conf b/etc/systemd/system/vdr.service.d/00-gentoo-vdr-user.conf
new file mode 100644
index 0000000..8f57598
--- /dev/null
+++ b/etc/systemd/system/vdr.service.d/00-gentoo-vdr-user.conf
@@ -0,0 +1,8 @@
+#
+# /etc/systemd/system/vdr.service.d/00-gentoo-vdr-user.conf
+#
+# use this file to override settings from vdr.service
+
+[Service]
+# uncomment this if you have to set START_VDR_AS_ROOT="yes" in /etc/conf.d/vdr
+#User=root
diff --git a/etc/systemd/system/vdr.service.d/Makefile b/etc/systemd/system/vdr.service.d/Makefile
new file mode 100644
index 0000000..9bb7610
--- /dev/null
+++ b/etc/systemd/system/vdr.service.d/Makefile
@@ -0,0 +1,16 @@
+# $Id: $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/etc/systemd/system/vdr.service.d
+SUBDIRS =
+BINS =
+CONFS = 00-gentoo-vdr-user.conf
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ @install -m 0644 -o root -g root $(CONFS) $(MYDIR)
+
+.PHONY: all install