summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-16 20:22:46 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-05-16 20:22:46 +0000
commit2a38ca26a418d158bc5e4dcda027049ab9515725 (patch)
tree51c27a24b62324aacf2c1870180292ff33e2d31c
parentReindent. (diff)
downloadpython-updater-2a38ca26a418d158bc5e4dcda027049ab9515725.tar.gz
python-updater-2a38ca26a418d158bc5e4dcda027049ab9515725.tar.bz2
python-updater-2a38ca26a418d158bc5e4dcda027049ab9515725.zip
Delete ChangeLog.
-rw-r--r--ChangeLog111
-rw-r--r--Makefile4
2 files changed, 2 insertions, 113 deletions
diff --git a/ChangeLog b/ChangeLog
deleted file mode 100644
index 9043ce4..0000000
--- a/ChangeLog
+++ /dev/null
@@ -1,111 +0,0 @@
-ChangeLog for python-updater
-============================
-
-This file lists all changes except typo and formatting fixes.
-
-2010-01-29 Arfrever Frehtes Taifersar Arahesis
-
- * python-updater: Delete eclass check, which causes many false positives,
- relies on deprecated PYVER variable and is incompatible with packages, which
- set active version of Python.
-
- * python-updater: Properly handle packages not supporting installation for multiple
- Python versions and calling python_set_active_version().
-
-2009-12-30 Arfrever Frehtes Taifersar Arahesis
-
- * python-updater: Don't support undocumented short options.
-
- * python-updater: Rename soname check to shared_linking. Add static_linking check.
-
- * python-updater: Properly handle Python modules installable for multiple Python
- versions. Bug #289253.
-
-2009-12-08 Arfrever Frehtes Taifersar Arahesis
-
- * python-updater: Use --keep-going option. Bug #281692.
-
- * python-updater: Fix handling of EMERGE_DEFAULT_OPTS. Bug #283284.
-
-2009-07-12 Arfrever Frehtes Taifersar Arahesis
-
- Tag version 0.7.
-
- * python-updater: Respect PACKAGE_MANAGER environment variable. Bug #272979.
-
- * python-updater: Replace --ignore-versions option with
- --reinstall-identical-versions option.
-
- * man.include, Makefile: Update python-updater.1.
-
- * python-updater: Allow to pass additional options to package manager. Bug #239174.
-
- * python-updater: Filter out --getbinpkg, --getbinpkgonly, --usepkg and
- --usepkgonly options in EMERGE_DEFAULT_OPTS environment variable. Bug #232304.
-
-2009-07-11 Arfrever Frehtes Taifersar Arahesis
-
- * python-updater: Avoid problems when '/var/db/pkg' is a symlink. Bug #232313.
-
- * python-updater: Check the version of '/usr/bin/python' instead of 'python'.
- Patch by Jeroen Roovers. Bug #256342.
-
- * python-updater: Update list of Python versions.
-
-2008-10-27 Ali Polatel
-
- * man.include, python-updater: Add need_rebuild check.
-
-2008-08-25 Ali Polatel
-
- Tag version 0.6.
-
- * python-updater: Echo the PMS command before running, #232860.
-
- * python-updater: Tell the user to use -o switch when no previous python versions
- are found, #232761.
-
- * python-updater: Make check manual print reason without --verbose, #232467.
-
-2008-06-21 Ali Polatel
-
- * python-updater, man.include, Makefile: List checks in help output
- and make indenting a bit nicer. Man page cosmetics.
-
-2008-06-20 Ali Polatel
-
- * python-updater: Fixed veinfo
-
- * python-updater, +man.include, +Makefile: Splitted checks and added command
- line options for them. Added new tests eclass and soname. Respect
- PYUPDATER_OPTIONS environment variable for default command line options.
- Bashified tests. Added man page and Makefile to do common tasks. Fixed ChangeLog.
-
-2008-01-04 Ali Polatel
-
- * +ChangeLog: Added ChangeLog
-
-2008-01-04 Ali Polatel
-
- * +AUTHORS: Added AUTHORS
-
-2007-12-13 Ali Polatel
-
- * python-updater: Don't ignore versions when SLOT doesn't exist,
- bug 201848
-
-2007-11-04 Ali Polatel
-
- * python-updater: be more specific when searching for package name
-
-2007-10-29 Ali Polatel
-
- * python-updater: added dev-libs/boost to PKGS_MANUAL
-
-2007-10-29 Ali Polatel
-
- * python-updater: imported python-updater from gentoo-python
-
-2007-10-29 Ali Polatel
-
- * .: added projects/python-updater
diff --git a/Makefile b/Makefile
index 1d6e74d..cb9e2f2 100644
--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
# Makefile for python-updater
MAN_INCLUDE=man.include
VERSION=$(shell ./python-updater -V)
-FILES=AUTHORS ChangeLog python-updater python-updater.1
+FILES=AUTHORS python-updater python-updater.1
PKGDIR=python-updater-$(VERSION)
TARBALL=$(PKGDIR).tar.bz2
@@ -18,7 +18,7 @@ clean:
tarball:
mkdir $(PKGDIR)
cp $(FILES) $(PKGDIR)
- tar cjf $(TARBALL) $(PKGDIR)
+ tar -cjf $(TARBALL) $(PKGDIR)
rm -fr $(PKGDIR)
upload:
scp $(TARBALL) dev.gentoo.org:/space/distfiles-local