summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-10-16 07:24:26 -0400
committerMichael Orlitzky <mjo@gentoo.org>2019-10-16 07:31:31 -0400
commit5114e1838d8531ebce400e668efec476b1c0815c (patch)
treeb4f6f79598f23b64b51a1839fc33dcc7bab95d69 /app-antivirus
parentapp-shells/bashdb: Removed old (diff)
downloadgentoo-5114e1838d8531ebce400e668efec476b1c0815c.tar.gz
gentoo-5114e1838d8531ebce400e668efec476b1c0815c.tar.bz2
gentoo-5114e1838d8531ebce400e668efec476b1c0815c.zip
app-antivirus/clamav: remove --disable-gcc-vcheck from configure flags.
Our ClamAV builds have passed the --disable-gcc-vcheck flag to its configure script for a while. This is intended to skip a (pointless, on Gentoo) test for old broken versions of GCC, but accidentally leads to "-O0" being inserted into the CFLAGS. That in turn causes noticeable performance degradation. Since the GCC version check is harmless aside from some wasted time, it seems the simplest solution here is to drop "--disable-gcc-vcheck" from the build. This commit adds a new revision of the latest unstable version that does just that. Closes: https://bugs.gentoo.org/670828 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/clamav-0.102.0-r1.ebuild (renamed from app-antivirus/clamav/clamav-0.102.0.ebuild)11
1 files changed, 5 insertions, 6 deletions
diff --git a/app-antivirus/clamav/clamav-0.102.0.ebuild b/app-antivirus/clamav/clamav-0.102.0-r1.ebuild
index 85d704dacfe6..1d65b447b4da 100644
--- a/app-antivirus/clamav/clamav-0.102.0.ebuild
+++ b/app-antivirus/clamav/clamav-0.102.0-r1.ebuild
@@ -74,12 +74,12 @@ src_configure() {
JSONUSE=""
if [ use clamsubmit ] || [ use metadata-analysis-api ]; then
- # either of those 2 requires libjson.
- # clamsubmit will be built as soon as libjson and curl are found
- # but we only install the binary if requested
- JSONUSE="--with-libjson=/usr"
+ # either of those 2 requires libjson.
+ # clamsubmit will be built as soon as libjson and curl are found
+ # but we only install the binary if requested
+ JSONUSE="--with-libjson=/usr"
else
- JSONUSE="--without-libjson"
+ JSONUSE="--without-libjson"
fi
econf \
@@ -98,7 +98,6 @@ src_configure() {
--with-system-libmspack \
--cache-file="${S}"/config.cache \
--disable-experimental \
- --disable-gcc-vcheck \
--disable-zlib-vcheck \
--enable-id-check \
--with-dbdir="${EPREFIX}"/var/lib/clamav \