summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-09 13:52:20 +0100
committerSam James <sam@gentoo.org>2024-10-09 13:52:36 +0100
commitefcad109bf466b26305cb3cd6be714971d3c50c7 (patch)
tree494005de1b3ad8bc45171a4c85af9e505f9314a6 /dev-db
parentdev-libs/libclc: Add 20.0.0_pre20241009 snapshot (diff)
downloadgentoo-efcad109bf466b26305cb3cd6be714971d3c50c7.tar.gz
gentoo-efcad109bf466b26305cb3cd6be714971d3c50c7.tar.bz2
gentoo-efcad109bf466b26305cb3cd6be714971d3c50c7.zip
dev-db/sqlitestudio: build with -j1
The build system is qmake so a pain to fix. Closes: https://bugs.gentoo.org/902991 Closes: https://bugs.gentoo.org/924672 Closes: https://bugs.gentoo.org/928736 Closes: https://bugs.gentoo.org/941074 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlitestudio/sqlitestudio-3.4.4-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-db/sqlitestudio/sqlitestudio-3.4.4-r1.ebuild b/dev-db/sqlitestudio/sqlitestudio-3.4.4-r1.ebuild
index 8d42774fa22e..5b746ecdf792 100644
--- a/dev-db/sqlitestudio/sqlitestudio-3.4.4-r1.ebuild
+++ b/dev-db/sqlitestudio/sqlitestudio-3.4.4-r1.ebuild
@@ -159,13 +159,14 @@ src_configure() {
}
src_compile() {
- emake -C "${core_build_dir}"
- emake -C "${plugins_build_dir}"
+ # -j1 for bug #902991; it clobbers object files in parallel
+ emake -j1 -C "${core_build_dir}"
+ emake -j1 -C "${plugins_build_dir}"
}
src_install() {
- emake -C "${core_build_dir}" INSTALL_ROOT="${D}" install
- emake -C "${plugins_build_dir}" INSTALL_ROOT="${D}" install
+ emake -j1 -C "${core_build_dir}" INSTALL_ROOT="${D}" install
+ emake -j1 -C "${plugins_build_dir}" INSTALL_ROOT="${D}" install
if use test; then
# remove test artifacts that must not be installed