summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-01-02 17:26:28 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2023-01-02 17:26:59 +0100
commit3c6c0a2c89073e3a8488a77ccc513d95da4436e6 (patch)
treec8929825072eee36a8d15f5d61805935f2e88c70 /sci-libs/pyshp
parentgames-emulation/pcsx2: update live (diff)
downloadgentoo-3c6c0a2c89073e3a8488a77ccc513d95da4436e6.tar.gz
gentoo-3c6c0a2c89073e3a8488a77ccc513d95da4436e6.tar.bz2
gentoo-3c6c0a2c89073e3a8488a77ccc513d95da4436e6.zip
sci-libs/pyshp: Add missing test dep
Closes: https://bugs.gentoo.org/888735 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'sci-libs/pyshp')
-rw-r--r--sci-libs/pyshp/pyshp-2.3.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-libs/pyshp/pyshp-2.3.1.ebuild b/sci-libs/pyshp/pyshp-2.3.1.ebuild
index af715dcb9263..dc041f721f8e 100644
--- a/sci-libs/pyshp/pyshp-2.3.1.ebuild
+++ b/sci-libs/pyshp/pyshp-2.3.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
-PYTHON_COMPAT=( python3_{7..11} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
@@ -20,7 +20,8 @@ RESTRICT="!test? ( test )"
RDEPEND=""
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {
epytest test_shapefile.py -m "not network" || die