summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/pyshp')
-rw-r--r--sci-libs/pyshp/pyshp-2.3.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-libs/pyshp/pyshp-2.3.1.ebuild b/sci-libs/pyshp/pyshp-2.3.1.ebuild
index af715dcb9263..dc041f721f8e 100644
--- a/sci-libs/pyshp/pyshp-2.3.1.ebuild
+++ b/sci-libs/pyshp/pyshp-2.3.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
-PYTHON_COMPAT=( python3_{7..11} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="Pure Python read/write support for ESRI Shapefile format"
@@ -20,7 +20,8 @@ RESTRICT="!test? ( test )"
RDEPEND=""
DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {
epytest test_shapefile.py -m "not network" || die