summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-11-14 18:06:29 -0500
committerMichael Orlitzky <mjo@gentoo.org>2024-11-14 18:29:55 -0500
commit50351306af64cc901edc4dc1704efa0b794673bc (patch)
tree36b89a2d2c9e640fb384b9f19e7b49690f6969ff /sci-mathematics
parentnet-analyzer/nagios-plugins: add 2.4.12 (diff)
downloadgentoo-50351306af64cc901edc4dc1704efa0b794673bc.tar.gz
gentoo-50351306af64cc901edc4dc1704efa0b794673bc.tar.bz2
gentoo-50351306af64cc901edc4dc1704efa0b794673bc.zip
sci-mathematics/eclib: add 20241112
Closes: https://bugs.gentoo.org/942122 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/eclib/Manifest1
-rw-r--r--sci-mathematics/eclib/eclib-20241112.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
index 194e412a262d..61d12360b0f7 100644
--- a/sci-mathematics/eclib/Manifest
+++ b/sci-mathematics/eclib/Manifest
@@ -1,2 +1,3 @@
DIST eclib-20231212.tar.bz2 926463 BLAKE2B 8105ac4014f9e44545d1d1e1cd5e18e36e467131b57a04a02d7e4f2390b0b0f78d0bac60dfbc0403a6681816a64a6e81c8d6a198f83bef991f697c2756a6d048 SHA512 692aa6bc2a52cd9496700990172b5a807abbd3f8bf8e931de14c48a401d1d383f95fa5def68bbf9a1aee08dfabac608604c0fd6f8bb49b813e6c6c909a2f27a7
DIST eclib-20240408.tar.bz2 918771 BLAKE2B e9f4a37973b40e73a111330800fcfebae91251613902b35ff29a45bdf3e7cd8cc49b061af121eff6aaa657d28b24b20ec00b77bad468504e545b3810852a50d2 SHA512 d93c724fa5816ce45a661d50000309e148fdbd0e287fbdbbf30bd6b3c6a7225846d90f11bc4d86c4b96111cbe8429b174e7d81ea0be1eef1a8acaa43287c09cf
+DIST eclib-20241112.tar.bz2 956725 BLAKE2B 09836c7203f246645a8287fe26c3ffd6fa06fd9ca7905c6e14aad162c91ce87f714914366416bc170b4595a70254d3cc62cd07c8158dfcac0b2ee57df0dc2d9d SHA512 8f559f9bd8580af85428981addcc93132d5f067c73d440ef31b43d697a49067365def07aeddc91b8346bb41acd5b4cdcc4ab8dcf716a5c3d6aa9ff394ff39b5a
diff --git a/sci-mathematics/eclib/eclib-20241112.ebuild b/sci-mathematics/eclib/eclib-20241112.ebuild
new file mode 100644
index 000000000000..a1eb3c2a4de6
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20241112.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+# COPYING is GPL-2 but the file headers say "or ... any later version"
+# LGPL-2.1+ is for bundled GetOpt.cc
+LICENSE="GPL-2+ LGPL-2.1+"
+
+# Subslot is from the soname, (LT_CURRENT - LT_AGE) in configure.ac.
+# (But for now, see src_prepare below.)
+SLOT="0/14"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}