summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-18 21:47:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-18 21:47:06 +0000
commit791b20bfc773818b43c1687aacfb1b52da6f91d2 (patch)
tree3a76bc9068cda8825a37c5f317c852c2d051f1e4 /dev-ml/ocaml-sqlite3
parentFixing nettle dep for stable pike too (diff)
downloadhistorical-791b20bfc773818b43c1687aacfb1b52da6f91d2.tar.gz
historical-791b20bfc773818b43c1687aacfb1b52da6f91d2.tar.bz2
historical-791b20bfc773818b43c1687aacfb1b52da6f91d2.zip
version bump
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/ocaml-sqlite3')
-rw-r--r--dev-ml/ocaml-sqlite3/ChangeLog8
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.6.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-ml/ocaml-sqlite3/ChangeLog b/dev-ml/ocaml-sqlite3/ChangeLog
index 33b086f231a1..25f1b11c1629 100644
--- a/dev-ml/ocaml-sqlite3/ChangeLog
+++ b/dev-ml/ocaml-sqlite3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocaml-sqlite3
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.15 2009/09/02 08:04:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.16 2009/09/18 21:42:57 aballier Exp $
+
+*ocaml-sqlite3-1.5.6 (18 Sep 2009)
+
+ 18 Sep 2009; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-sqlite3-1.5.6.ebuild:
+ version bump
*ocaml-sqlite3-1.5.3 (02 Sep 2009)
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.6.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.6.ebuild
new file mode 100644
index 000000000000..376b3a83b632
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.5.6.ebuild,v 1.1 2009/09/18 21:42:57 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to SQLite databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#ocaml-sqlite3"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ >=dev-db/sqlite-3.3.3"
+
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.22.0-destdir.patch"
+ epatch "${FILESDIR}/${PN}-0.23.0-noocamlopt.patch"
+ epatch "${FILESDIR}/${PN}-1.5.1-werror.patch"
+}
+
+src_compile() {
+ emake -j1 bytecode || die "make bytecode failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make opt failed"
+ fi
+ if use doc; then
+ emake -j1 docs || die "make doc failed"
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ export OCAMLPATH="${OCAMLFIND_DESTDIR}"
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc Changelog README.txt TODO
+ use doc && dohtml doc/*
+}