summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-07 20:39:27 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-07 20:39:27 +0000
commit5ee8321fdf64b936271655d38e6a1d908df3a4d4 (patch)
treeff3198a329730248038565822c9e9c5e4cfbb48b /dev-python/lp_solve/lp_solve-5.5.2.0.ebuild
parentBump to 0.7.159, development version (diff)
downloadhistorical-5ee8321fdf64b936271655d38e6a1d908df3a4d4.tar.gz
historical-5ee8321fdf64b936271655d38e6a1d908df3a4d4.tar.bz2
historical-5ee8321fdf64b936271655d38e6a1d908df3a4d4.zip
Initial import to the main tree
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'dev-python/lp_solve/lp_solve-5.5.2.0.ebuild')
-rw-r--r--dev-python/lp_solve/lp_solve-5.5.2.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/lp_solve/lp_solve-5.5.2.0.ebuild b/dev-python/lp_solve/lp_solve-5.5.2.0.ebuild
new file mode 100644
index 000000000000..895aad7aac03
--- /dev/null
+++ b/dev-python/lp_solve/lp_solve-5.5.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/lp_solve/lp_solve-5.5.2.0.ebuild,v 1.1 2012/01/07 20:36:32 bicatali Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="2.4 3*"
+
+inherit distutils eutils
+
+DESCRIPTION="Python wrappers for lpsolve"
+HOMEPAGE="http://lpsolve.sourceforge.net/5.5/Python.htm"
+SRC_URI="mirror://sourceforge/lpsolve/${PN}_${PV}_Python_source.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-python/numpy
+ sci-mathematics/lpsolve"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${PN}_5.5/extra/Python/"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-setup.patch
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" \
+ "$(PYTHON)" lpdemo.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ dodoc changes
+ use doc && dohtml Python.htm
+ insinto /usr/share/doc/${PF}/examples
+ use examples && doins ex*py
+}