summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-09 22:41:54 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-09 22:41:54 +0000
commitc307bad1bc065e100ff558e118478c32b83a5d45 (patch)
treeee50dca319552918081854bb01cbf6b106f1cd0b /net-im
parentoops ;/ (diff)
downloadhistorical-c307bad1bc065e100ff558e118478c32b83a5d45.tar.gz
historical-c307bad1bc065e100ff558e118478c32b83a5d45.tar.bz2
historical-c307bad1bc065e100ff558e118478c32b83a5d45.zip
updated, now installs into thanks to Aron's nice script :)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gnomeicu/files/digest-gnomeicu-0.96.1-r3 (renamed from net-im/gnomeicu/files/digest-gnomeicu-0.96.1-r2)0
-rw-r--r--net-im/gnomeicu/gnomeicu-0.96.1-r2.ebuild56
-rw-r--r--net-im/gnomeicu/gnomeicu-0.96.1-r3.ebuild53
3 files changed, 53 insertions, 56 deletions
diff --git a/net-im/gnomeicu/files/digest-gnomeicu-0.96.1-r2 b/net-im/gnomeicu/files/digest-gnomeicu-0.96.1-r3
index 31dc6d042ec2..31dc6d042ec2 100644
--- a/net-im/gnomeicu/files/digest-gnomeicu-0.96.1-r2
+++ b/net-im/gnomeicu/files/digest-gnomeicu-0.96.1-r3
diff --git a/net-im/gnomeicu/gnomeicu-0.96.1-r2.ebuild b/net-im/gnomeicu/gnomeicu-0.96.1-r2.ebuild
deleted file mode 100644
index 3ad30adadc7e..000000000000
--- a/net-im/gnomeicu/gnomeicu-0.96.1-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Distributed under the terms of the GNU General Public License, v2 or later
-# A Gnome ICQ Clone
-# Author Ben Lutgens <blutgens@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-im/gnomeicu/gnomeicu-0.96.1-r2.ebuild,v 1.1 2001/10/06 17:22:52 azarah Exp $
-
-
-A=${P}.tar.bz2
-S=${WORKDIR}/${P}
-DESCRIPTION="Gnome ICQ Client"
-SRC_URI="http://download.sourceforge.net/gnomeicu/${A}"
-HOMEPAGE="http://gnomeicu.sourceforge.net/"
-
-DEPEND="virtual/glibc sys-devel/gettext
- >=gnome-base/gnome-core-1.4.0.4-r1
- >=sys-libs/gdbm-1.8.0"
-RDEPEND=">=gnome-base/gnome-core-1.4.0.4-r1
- >=sys-libs/gdbm-1.8.0"
-
-src_unpack() {
- unpack ${A}
- cd ${S}/src
- cp ${FILESDIR}/userserver.patch .
- patch -p0 < userserver.patch
-}
-
-src_compile() {
-
-
- local myconf
- local myprefix
- myprefix="/usr"
- if [ -z "`use esd`" ]
- then
- myconf="--disable-esd-test"
- fi
- if [ "`use socks5`" ];
- then
- myconf="${myconf} --enable-socks5"
- fi
-
-# This is busted, I'm not sure if it's my box or what, I don't have nls in use
-# so the disabling should work perfectly.
-#
-# if [ -z "`use nls`" ]
-# then
-# myconf="${myconf} --disable-nls"
-# fi
- try ./configure --host=${CHOST} ${myconf} --prefix=${myprefix}
- try make
-}
-
-src_install() {
-
- try make DESTDIR=${D} install
- dodoc AUTHORS COPYING CREDITS ChangeLog INSTALL NEWS README TODO ABOUT-NLS
-}
diff --git a/net-im/gnomeicu/gnomeicu-0.96.1-r3.ebuild b/net-im/gnomeicu/gnomeicu-0.96.1-r3.ebuild
new file mode 100644
index 000000000000..6777f2c104b0
--- /dev/null
+++ b/net-im/gnomeicu/gnomeicu-0.96.1-r3.ebuild
@@ -0,0 +1,53 @@
+# Distributed under the terms of the GNU General Public License, v2 or later
+# A Gnome ICQ Clone
+# Author Ben Lutgens <blutgens@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-im/gnomeicu/gnomeicu-0.96.1-r3.ebuild,v 1.1 2001/11/09 22:41:54 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gnome ICQ Client"
+SRC_URI="http://download.sourceforge.net/gnomeicu/${P}.tar.bz2"
+HOMEPAGE="http://gnomeicu.sourceforge.net/"
+
+RDEPEND=">=gnome-base/gnome-core-1.4.0.4-r1
+ >=sys-libs/gdbm-1.8.0"
+
+DEPEND="${RDEPEND}
+ virtual/glibc
+ sys-devel/gettext"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ cp ${FILESDIR}/userserver.patch .
+ patch -p0 < userserver.patch
+}
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use esd`" ]
+ then
+ myconf="--disable-esd-test"
+ fi
+ if [ "`use socks5`" ];
+ then
+ myconf="${myconf} --enable-socks5"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/log \
+ install || die
+
+ dodoc AUTHORS COPYING CREDITS ChangeLog NEWS README TODO ABOUT-NLS
+}