aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-05-20 07:39:29 +0300
committerStefan Strogin <steils@gentoo.org>2020-05-21 18:01:47 +0300
commit9ec68a2b38711f1711b17d1cf3b14c3ada480897 (patch)
tree8d37e2c7d7421731500c87c8bda98d2d7088ac60
parentnet-im/riot-web: drop 9999 (diff)
downloadmatrix-9ec68a2b38711f1711b17d1cf3b14c3ada480897.tar.gz
matrix-9ec68a2b38711f1711b17d1cf3b14c3ada480897.tar.bz2
matrix-9ec68a2b38711f1711b17d1cf3b14c3ada480897.zip
net-im/riot-desktop: add new package, version 1.6.1
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--net-im/riot-desktop/Manifest2
-rw-r--r--net-im/riot-desktop/metadata.xml11
-rw-r--r--net-im/riot-desktop/riot-desktop-1.6.1.ebuild96
3 files changed, 109 insertions, 0 deletions
diff --git a/net-im/riot-desktop/Manifest b/net-im/riot-desktop/Manifest
new file mode 100644
index 0000000..24e874e
--- /dev/null
+++ b/net-im/riot-desktop/Manifest
@@ -0,0 +1,2 @@
+DIST riot-desktop-1.6.1.tar.gz 401222 BLAKE2B dbc3aaefce9a727025c341b03c657edd348eabd22efd2285558939d460941ad85adae65d9e13be2445baaf958f018f6afa071670eae81d13e875abbbf62417af SHA512 8ff8ba30088d0caee6a45fbd1b7b70554b69344603d93d9c555be0dc4120a4dcfe99819ca06deab8bd66f535761215a832f2e69084b61738a1263497e185b404
+DIST riot-web-1.6.1.tar.gz 1150368 BLAKE2B 51437fa1e0a8e62ca34dcae2701b807bba95c2071439ffff129812b975c997afc867cffd3aceef926358eeecab82b615d91b90b08672465052f695573052c2f4 SHA512 36603d19984aed6586100497a35642e061d5d8a679ff10c18e24a6bb7c865a7262e4fd57d42085e7cd7df0d6563408cb031b2c07ca73b57f11791095ac499028
diff --git a/net-im/riot-desktop/metadata.xml b/net-im/riot-desktop/metadata.xml
new file mode 100644
index 0000000..96ca388
--- /dev/null
+++ b/net-im/riot-desktop/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>steils@gentoo.org</email>
+ <name>Stefan Strogin</name>
+ </maintainer>
+ <use>
+ <flag name="emoji">Use <pkg>media-fonts/noto-emoji</pkg> for displaying emoji</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-im/riot-desktop/riot-desktop-1.6.1.ebuild b/net-im/riot-desktop/riot-desktop-1.6.1.ebuild
new file mode 100644
index 0000000..01c45d4
--- /dev/null
+++ b/net-im/riot-desktop/riot-desktop-1.6.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A glossy Matrix collaboration client for desktop"
+HOMEPAGE="https://riot.im"
+
+inherit unpacker xdg-utils
+
+SRC_URI="https://github.com/vector-im/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/vector-im/riot-web/archive/v${PV}.tar.gz -> riot-web-${PV}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+emoji"
+REQUIRED_USE=""
+
+RDEPEND="dev-libs/nss
+ gnome-base/gconf
+ >=net-libs/nodejs-12.14.0
+ net-print/cups
+ x11-libs/libXScrnSaver
+ emoji? ( media-fonts/noto-emoji )"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/yarn
+ virtual/rust"
+
+QA_PREBUILT="
+ /opt/Riot/chrome-sandbox
+ /opt/Riot/crashpad_handler
+ /opt/Riot/riot-desktop
+ /opt/Riot/libEGL.so
+ /opt/Riot/libGLESv2.so
+ /opt/Riot/libffmpeg.so
+ /opt/Riot/libvk_swiftshader.so
+ /opt/Riot/swiftshader/libEGL.so
+ /opt/Riot/swiftshader/libGLESv2.so"
+
+RIOT_WEB_S="${WORKDIR}/riot-web-${PV}"
+
+src_prepare() {
+ default
+ cd "${RIOT_WEB_S}" || die
+ yarn install || die
+ cp config.sample.json config.json || die
+
+ cd "${S}" || die
+ yarn install || die
+}
+
+src_compile() {
+ cd "${RIOT_WEB_S}" || die
+ yarn build || die
+
+ cd "${S}" || die
+ ln -s "${RIOT_WEB_S}"/webapp ./ || die
+ yarn build:native || die
+ yarn build || die
+}
+
+src_install() {
+ unpack dist/${PN}_${PV}_amd64.deb
+ tar -xvf data.tar.xz || die
+
+ ./node_modules/asar/bin/asar.js p webapp opt/Riot/resources/webapp.asar || die
+ mv usr/share/doc/${PN} usr/share/doc/${PF} || die
+ gunzip usr/share/doc/${PF}/changelog.gz || die
+
+ insinto /
+ doins -r usr
+ doins -r opt
+ local f
+ for f in ${QA_PREBUILT}; do
+ fperms +x "${f}"
+ done
+ dosym ../../opt/Riot/${PN} /usr/bin/${PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "Since upgrading Riot to Electron 8 it uses StatusNotifierItem"
+ elog "for displaying the tray icon."
+ elog "Some popular status bars do not support the new API."
+ elog
+ elog "If you have problems with showing the tray icon, consider installing"
+ elog "x11-misc/snixembed."
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}