summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2024-10-08 04:21:39 -0400
committerFlorian Schmaus <flow@gentoo.org>2024-10-14 09:14:00 +0200
commitc8ab83d2bb117c3b737758b0c04ab9f4321badd7 (patch)
tree6b1b11d078a3ae87997cd54c4ce78d48de50dde5
parentdev-cpp/gtest: add ~arm64-macos keyword (diff)
downloadgentoo-c8ab83d2bb117c3b737758b0c04ab9f4321badd7.tar.gz
gentoo-c8ab83d2bb117c3b737758b0c04ab9f4321badd7.tar.bz2
gentoo-c8ab83d2bb117c3b737758b0c04ab9f4321badd7.zip
dev-cpp/gtest: use CMAKE_SKIP_TESTS to filter tests
Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index b0cdccd02275..f86a47387a97 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -34,6 +34,9 @@ RESTRICT="!test? ( test )"
BDEPEND="test? ( ${PYTHON_DEPS} )"
+# Exclude tests that fail with FEATURES="usersandbox"
+CMAKE_SKIP_TESTS=( "googletest-(death-test|port)-test" )
+
pkg_setup() {
use test && python-any-r1_pkg_setup
}
@@ -61,11 +64,6 @@ multilib_src_configure() {
cmake_src_configure
}
-multilib_src_test() {
- # Exclude tests that fail with FEATURES="usersandbox"
- cmake_src_test -E "googletest-(death-test|port)-test"
-}
-
multilib_src_install_all() {
einstalldocs