summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@protonmail.com>2023-01-06 10:37:54 -0600
committerSam James <sam@gentoo.org>2023-01-07 00:06:06 +0000
commit13d407057928f96ce29ef4988b7bd4400db8c060 (patch)
tree55ce2202a4e92a8f390ee0252147fa0857449170 /app-shells
parentdev-libs/redis-ipc: add 0.1.0, drop 0.0.6 (diff)
downloadgentoo-13d407057928f96ce29ef4988b7bd4400db8c060.tar.gz
gentoo-13d407057928f96ce29ef4988b7bd4400db8c060.tar.bz2
gentoo-13d407057928f96ce29ef4988b7bd4400db8c060.zip
app-shells/bash: fix build with gcc and USE=pgo
Closes: https://bugs.gentoo.org/889848 Signed-off-by: Leonardo Hernández Hernández <leohdz172@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/28985 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/bash-5.2_p15.ebuild4
-rw-r--r--app-shells/bash/bash-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/app-shells/bash/bash-5.2_p15.ebuild b/app-shells/bash/bash-5.2_p15.ebuild
index a1a2a14ae0e4..9dbde4810a73 100644
--- a/app-shells/bash/bash-5.2_p15.ebuild
+++ b/app-shells/bash/bash-5.2_p15.ebuild
@@ -246,7 +246,9 @@ src_compile() {
emake CFLAGS="${CFLAGS} -fprofile-generate=${T}/pgo -fprofile-dir=${T}/pgo" -k check
- tc-is-clang && llvm-profdata merge "${T}"/pgo --output="${T}"/pgo/default.profdata || die
+ if tc-is-clang; then
+ llvm-profdata merge "${T}"/pgo --output="${T}"/pgo/default.profdata || die
+ fi
# Rebuild Bash using the profiling data we just generated.
emake clean
diff --git a/app-shells/bash/bash-9999.ebuild b/app-shells/bash/bash-9999.ebuild
index b0207e51036e..b491dd7b04e3 100644
--- a/app-shells/bash/bash-9999.ebuild
+++ b/app-shells/bash/bash-9999.ebuild
@@ -246,7 +246,9 @@ src_compile() {
emake CFLAGS="${CFLAGS} -fprofile-generate=${T}/pgo -fprofile-dir=${T}/pgo" -k check
- tc-is-clang && llvm-profdata merge "${T}"/pgo --output="${T}"/pgo/default.profdata || die
+ if tc-is-clang; then
+ llvm-profdata merge "${T}"/pgo --output="${T}"/pgo/default.profdata || die
+ fi
# Rebuild Bash using the profiling data we just generated.
emake clean