summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-13 11:03:57 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-13 11:17:36 -0500
commit87fdf733c9aa35a17faae23f78156c62bb2fcce6 (patch)
tree5a6697f5e17317e0e39bf41d4ac812227f7d1274 /dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild
parentdev-php/PEAR-Cache_Lite: Version bump to 1.8.2 (diff)
downloadgentoo-87fdf733c9aa35a17faae23f78156c62bb2fcce6.tar.gz
gentoo-87fdf733c9aa35a17faae23f78156c62bb2fcce6.tar.bz2
gentoo-87fdf733c9aa35a17faae23f78156c62bb2fcce6.zip
dev-php/PEAR-Console_Getargs: Version bump to 1.4.0 with PHP 7 support
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild')
-rw-r--r--dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild b/dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild
new file mode 100644
index 000000000000..58692f2f12eb
--- /dev/null
+++ b/dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit php-pear-r2
+
+DESCRIPTION="A command-line arguments parser"
+
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-php/phpunit )"
+
+src_test() {
+ phpunit tests/ || die
+}