summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild')
-rw-r--r--dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild b/dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild
new file mode 100644
index 000000000000..58692f2f12eb
--- /dev/null
+++ b/dev-php/PEAR-Console_Getargs/PEAR-Console_Getargs-1.4.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit php-pear-r2
+
+DESCRIPTION="A command-line arguments parser"
+
+LICENSE="PHP-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-php/phpunit )"
+
+src_test() {
+ phpunit tests/ || die
+}