summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-27 07:29:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-27 07:29:52 +0100
commit1e6b0a07cff60174c67b7baf4546b43a99eeb10f (patch)
tree630d61e2579378381838b218b2ea1b267bf847a9 /dev-python/marshmallow
parentdev-python/ipykernel: Bump to 6.29.3 (diff)
downloadgentoo-1e6b0a07cff60174c67b7baf4546b43a99eeb10f.tar.gz
gentoo-1e6b0a07cff60174c67b7baf4546b43a99eeb10f.tar.bz2
gentoo-1e6b0a07cff60174c67b7baf4546b43a99eeb10f.zip
dev-python/marshmallow: Bump to 3.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow')
-rw-r--r--dev-python/marshmallow/Manifest1
-rw-r--r--dev-python/marshmallow/marshmallow-3.21.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/marshmallow/Manifest b/dev-python/marshmallow/Manifest
index 88f9a0120259..c18b24621aae 100644
--- a/dev-python/marshmallow/Manifest
+++ b/dev-python/marshmallow/Manifest
@@ -1 +1,2 @@
DIST marshmallow-3.20.2.gh.tar.gz 183876 BLAKE2B 84cf8ca23069ad1d2353ffa9299556298457485fa459746b948835f04f92ef3949d5429e8285e084be7398fb294b3d74eba1b38ef21b469daed401f1e6affcdb SHA512 8305693405a976c53333b0c6ef074a12af4736f9620ca37c7c2ec6318fac2b19086426344ce8c2f515e95becdba8b2bb1c20aca5a9dffb4145cb27fee00dc080
+DIST marshmallow-3.21.0.gh.tar.gz 183738 BLAKE2B 9f9b9203be93e6feecbd6b7e1da32f737ba33ca8e386e062d091e20480f5241c1d73f77afd542cb24816a48aa5a948aaa20edcfe9d0fdfa847f6e405e89cff20 SHA512 d08e4eedafc1d6f2bfab463357febc75013e8a548195ab85aac55fa225f2180a4f1646d68f8586d369dd108a793086c5bb8522c7543a51540ec4ee6de5305ad3
diff --git a/dev-python/marshmallow/marshmallow-3.21.0.ebuild b/dev-python/marshmallow/marshmallow-3.21.0.ebuild
new file mode 100644
index 000000000000..2adebae08366
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.21.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for converting to and from native Python datatypes"
+HOMEPAGE="
+ https://github.com/marshmallow-code/marshmallow/
+ https://pypi.org/project/marshmallow/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/marshmallow/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-17.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest