summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pyechonest
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pyechonest')
-rw-r--r--dev-python/pyechonest/Manifest2
-rw-r--r--dev-python/pyechonest/metadata.xml30
-rw-r--r--dev-python/pyechonest/pyechonest-7.2.1.ebuild38
-rw-r--r--dev-python/pyechonest/pyechonest-9.0.0.ebuild38
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-python/pyechonest/Manifest b/dev-python/pyechonest/Manifest
new file mode 100644
index 000000000000..92fb7a5941be
--- /dev/null
+++ b/dev-python/pyechonest/Manifest
@@ -0,0 +1,2 @@
+DIST pyechonest-7.2.1.tar.gz 66314 SHA256 5f2279386daf6f9080a633a0ab508fc92c281d2279e29ff4d16a75fea4111b66 SHA512 f77f12355d9243f61ebf8612c94d99222b7ab010d7ef0ff911ceab5581084ac75c450bd538860c213233ac45483ba173f2d21fa0bba8d01480d02f339560b8d0 WHIRLPOOL b633143a23f8d2daa2371a5b2767a72a267cf96f79a73f98279026aa4bf45f84aa55249473efea9eeacbc34b20497607446300c73af448646a61439794d82f34
+DIST pyechonest-9.0.0.tar.gz 63654 SHA256 87d7782d60cb16d84cbd34406154e3e221c9ca0bf977bda1ef73b315d0065372 SHA512 6eaadc08a4e23d8de86ff7b254d271349bd0a766ae1aa7dfa28dc59ae591d5b31aa109e6075fd7db98e3d03b990ab118cd8d5f2e67247988c3de0c5c3a222d66 WHIRLPOOL 1f96e8b447756cd298ad779070ff23b6639b5c61389d3c134a80ea5821b4d4e366dc9e49be5698eb66166415591623bf17b6d6c03c0a3a36836040c2fdc22b0b
diff --git a/dev-python/pyechonest/metadata.xml b/dev-python/pyechonest/metadata.xml
new file mode 100644
index 000000000000..77ada575eb71
--- /dev/null
+++ b/dev-python/pyechonest/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ Tap into The Echo Nest's Musical Brain for the best music search,
+ information, recommendations and remix tools on the web.
+
+ Pyechonest is an open source Python library for the Echo Nest API. With
+ Pyechonest you have Python access to the entire set of API methods
+ including:
+ artist - search for artists by name, description, or attribute, and
+ get back detailed information about any artist including
+ audio, similar artists, blogs, familiarity, hotttnesss,
+ news, reviews, urls and video.
+ song - search songs by artist, title, description, or attribute
+ (tempo, duration, etc) and get detailed information back
+ about each song, such as hotttnesss, audio_summary, or
+ tracks.
+ track - upload a track to the Echo Nest and receive summary
+ information about the track including key, duration, mode,
+ tempo, time signature along with detailed track info
+ including timbre, pitch, rhythm and loudness information.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">echonest/pyechonest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyechonest/pyechonest-7.2.1.ebuild b/dev-python/pyechonest/pyechonest-7.2.1.ebuild
new file mode 100644
index 000000000000..ca93c148a5b4
--- /dev/null
+++ b/dev-python/pyechonest/pyechonest-7.2.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to The Echo Nest APIs"
+HOMEPAGE="http://echonest.github.com/pyechonest/"
+SRC_URI="https://github.com/echonest/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyechonest/pyechonest-9.0.0.ebuild b/dev-python/pyechonest/pyechonest-9.0.0.ebuild
new file mode 100644
index 000000000000..2789ead3a04f
--- /dev/null
+++ b/dev-python/pyechonest/pyechonest-9.0.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to The Echo Nest APIs"
+HOMEPAGE="http://echonest.github.com/pyechonest/"
+SRC_URI="https://github.com/echonest/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "s/, 'sphinx.ext.intersphinx'//" -i doc/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}