summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-01-11 16:37:43 -0800
committerZac Medico <zmedico@gentoo.org>2016-01-11 16:37:43 -0800
commit316a03f75cfc06b16e63aae63f0f9734c3f45107 (patch)
tree9f6f424236ca39ae92a1d02e0860904bb870042d /dev-python/python-engineio
parentnet-fs/samba-4.3.3: convert to multilib (diff)
downloadgentoo-316a03f75cfc06b16e63aae63f0f9734c3f45107.tar.gz
gentoo-316a03f75cfc06b16e63aae63f0f9734c3f45107.tar.bz2
gentoo-316a03f75cfc06b16e63aae63f0f9734c3f45107.zip
dev-python/python-engineio: version bump to 0.8.6
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/python-engineio')
-rw-r--r--dev-python/python-engineio/Manifest1
-rw-r--r--dev-python/python-engineio/python-engineio-0.8.6.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-engineio/Manifest b/dev-python/python-engineio/Manifest
index f12a2b0b672c..185bed62d7e4 100644
--- a/dev-python/python-engineio/Manifest
+++ b/dev-python/python-engineio/Manifest
@@ -1 +1,2 @@
DIST python-engineio-0.8.1.tar.gz 11608 SHA256 82973bcf1c32df594bb78c527d9406f301691ecc5ab93c38fc318c1b0142b9fd SHA512 71a6002753f77440fe118004e7ace11eeb348b2d63274e81fe66e8eace899b8b3f1b8b130f86cedb0d78c995f1f83053ab7811e68fbb6e977072d9491a35b6b7 WHIRLPOOL c2a62848b2a83adb5eea255c60c77d6355053a360d885dacfe117a104974987c9379236c62eed6f496e115c8181428a09ccd51720438b4110902b43c06778450
+DIST python-engineio-0.8.6.tar.gz 11855 SHA256 cdb7381d6ba28d13e02cec61f3d1b254341b784452c629fba524784c0b774363 SHA512 4fd4e492655340798ca7c34127d26d0fcba864b95e3ab21c423867c21ee7d37dd3b5f564bd3013cc0f9f235a57b5dd4bf705648e21cf07fbe417e4fa69e632f2 WHIRLPOOL df96a513112a21b3dbc4262f156d4332ca71547d0882a0cc473a128a8c3a9ca1dd5a29b19e2b56f5b819fdc8ea415b8f092f974fd2d35f963e321dc2afdd0375
diff --git a/dev-python/python-engineio/python-engineio-0.8.6.ebuild b/dev-python/python-engineio/python-engineio-0.8.6.ebuild
new file mode 100644
index 000000000000..53e64a8376b0
--- /dev/null
+++ b/dev-python/python-engineio/python-engineio-0.8.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN=""
+DESCRIPTION="Python implementation of the Engine.IO realtime server."
+HOMEPAGE="https://${PN}.readthedocs.org/ https://github.com/miguelgrinberg/${PN}/ https://pypi.python.org/pypi/${PN}"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+src_prepare() {
+ sed -e 's:pbr<1.7.0:pbr:' -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ esetup.py test || die
+}